x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why won't my NavMesh show when I press P?

My level includes a very large NavMeshBounds Volume, and I have spawning Blueprint static meshes to make up the playable surface. I have added a Navigation Invoker to my player character and I've turned on Runtime generation to Dynamic.

When I run the game, I try to view paths by pressing ', followed by num 0. However, the debug menu shows the Navmesh section greyed out (as shown below). (EDIT: I was being an idiot and not viewing through the console command "show navigation", that works as expected).

alt text

I can only assume that the NavMesh is not being built. Is this because there's no NavMesh to show? No geometry exists in the level until runtime, might this be related?

EDIT: I've run a test where I'm using static meshes which exist as actors in the level to see if the NavMesh will build on that. Same result.

EDIT2: So I've progressed a bit. I can now see my NavMesh generating on static meshes which exist in the level (the EDIT above's problem). I'm still not seeing it appear on spawned blueprint meshes which is my overall goal. The property in the mesh editor "Is Dynamic Obstacle" appears to be one of the key factors. Turning it on and off allows it to generate Navmesh on the in-world static mesh or not. I read elsewhere that setting the area class to Nav_Area_Obstacle allowed for spawned meshes to be detected, but it's not what I'm seeing.

Product Version: UE 4.13
Tags:
navmesh_debug1.png (251.3 kB)
more ▼

asked Nov 08 '16 at 10:41 AM in Using UE4

avatar image

Benni.Lodge
28 2 7 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question