x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Timed Particles Persona not working during play

For one of the cutscenes in Rad Rodgers I am adding all kinds of effects to the big talking, ex-husband smoking elder tree and since most of them are timed and need to be attached on sockets, I am using persona for this.

The timed particles show up fine inside Persona and when previewing the whole cutscene inside matinee, but during play-mode/standalone/etc they dont show up, arent drawn, dont appear, etc.

  • Tested things:
    • Not particle LOD

    • Not a weird shader that causes em to not being visible.

    • Tested on a variety computers in a variety of locations around the globe.

    • Engine settings are correct. (pie settings etc)

    • Bounds are correct.

    • There is no collision affecting this.

    • No weird loop/offset/particle node stuff.

    • Particles run fine on their own.

    • VFX do play in playmode when animation is not controlled by animbp/matinee.

    • Nothing in animbp/Matinee that dictates vfx should not play.

    • One shot vfx do play during playmode, only the timed particles (Add notify state > timed particle effect) are not working.

    • No weird PostProcess setting.

    • Nothing occluding them.

    • Not even the sprite is drawn.

    • Nothing shows up in wireframe mode.

    • No change when moving to another ue4 version, but due to current state of production moving to another ue4 version is (currently)out of the question.

    • Tried anything & everything I could find when searching on answerhub/google/forums.

    • Knocked on wood, kissed a cat, put a shoe on my head, prayed to the holy Eric & Nick, nothing.

    • Cant show or send project, though a private viewing/solving to one of the epic-devs is permitted.

.

thoughts?

Product Version: UE 4.12
Tags:
more ▼

asked Nov 08 '16 at 01:08 PM in Using UE4

avatar image

Luos
9.3k 286 65 332

avatar image AndrewHurley Nov 10 '16 at 08:43 PM

Hey Luos,

Finally getting around to this post. After reading all your points, as you know it is going to be hard to determine what is going on without a repro case in a minimal project.

With that said, I have a guess that it could be you have the particle set to auto-activate and matinee could require you to activate the particle through an event or something along those lines where it is controlled on the game side.

I do have a suggestion, that might require rework if this is a work stop issue, and it involves moving over to Sequencer from Matinee as it has been marked as the legacy cinematics editor.

Feel free to send me a pm on the Forums with any other example videos or information you can provide.

Thanks,

Andrew Hurley

avatar image Luos Nov 10 '16 at 11:42 PM

Hey Andrew! thanks for the reply!

Ill pass the answer onto the rest of the team as well, sadly so far into production moving over to sequencer might not be a thing.

Shouldn't vfx in persona not just always work? I mean, in cases where its optional one would expect a tickbox for "always activate" or something like it? Especially since one-shots do work.

As for sending the project, I doubt there is a proper way of doing that as so much is tied together but I can give it a shot when I have some spare time. I will record a video (as detailed as possible) tomorrow so you can take a look that way, at least.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

So I took a look at your video and there is a lot there :)

I think you have narrowed it down to being an issue with how the particle system is called to play in game with Matinee. I have a few suggestions for you and your team that should provide some resolution.

Firstly, I would create a minimal project test case using the particle systems in question and a matinee cinematic. Call those particles to play the same as you would within the matinee of your current project. If they work correctly when you play the game, then I would directly compare the differences of how the two particles systems are being called between projects.

This could involve going into that character blueprint for the character using the anim notifies, and make sure the particle systems, components or otherwise, are using the exact same settings as the ones that worked in your minimal test case. Aside from that there is an alternative option, and perhaps I should have clarified this a bit in my previous statement about moving to Sequencer.

There is an option if you right click on the matinee actor placed in your level, you can select to convert it to a Level Sequence. This should keep all your keyframes and events in place, and simply move it to a level sequence. We have officially moved away from Matinee as our Cinematics editor and have replaced it with Sequencer. Moving to this Editor will open up more options and ways to troubleshoot and visualize issues like these. It as user friendly and shares similarities with other video editing software applications for ease of transition and quicker understanding.

My final suggest would be to go the old fashioned way and force the particle systems to play while they are placed in the level. Give them their own custom events, and call those events via blueprints connected to matinee. I hope these have been helpful and give you a way to move forward with your development. It looks good and I look forward to the final result :)

Cheers,

Andrew Hurley

more ▼

answered Nov 15 '16 at 07:31 PM

avatar image Luos Nov 16 '16 at 11:19 AM

Hey Hey Andrew! thanks for the extensive reply!

I havent tried them all yet, but the mayor one moving to sequencer did not result in any potential solutions. Besides one small hickup everything works.. but the particles are not playing and no additional options for it available in sequencer.

Minimal test case and old fashioned way will be tested asap.

avatar image Luos Nov 17 '16 at 03:14 PM

Hey Andrew,

Eventually we settled for the following: Just attach the particles to the sockets on the skeletal meshes by placing them into the level > attach to > skeletal mesh > sockets. then while having the particle selected > new particle thingy in matinee > turn on/off. which resulted in working fine :)

alt text

avatar image AndrewHurley Nov 17 '16 at 04:58 PM

Yeah, seems like you guys had to do a bit more of a forceful way of getting the particle system to play as expected, but I am glad you have gotten it to work. I appreciate the virtual hug you passed along by the way :)

Best of luck with the rest of the project.

Regards,

Andrew Hurley

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question