x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can't find session in LAN

So, what is the right way to use the LAN feature.

I have [OnlineSubsystem] DefaultPlatformService=Null in my default engine.ini and PrivateDependencyModuleNames.Add("OnlineSubsystemNull"); in my build.cs

Use LAN is checked

I can create a session but can't find it on another computer, it said the sessionlist's size is 0. I can also use "open 192.168.4.104" to join the game.

is there something I missed?

but everything worked fine on one computer(findsession,joinsession)

Product Version: UE 4.11
Tags:
more ▼

asked Nov 09 '16 at 10:50 AM in Using UE4

avatar image

zhoudao200
41 2 6 16

avatar image zhoudao200 Nov 09 '16 at 11:59 AM

I tried multiplayerShootOut but changed to onlinesubsystemNull, same issue. computer's firewall closed.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

fixed, just turn off your computer's VirtualBox NetWork Adapter or something like that.

more ▼

answered Nov 10 '16 at 02:30 AM

avatar image

zhoudao200
41 2 6 16

avatar image vito0719 Mar 08 '17 at 02:30 PM

savior!!!!!!

avatar image ENiari Games Jul 11 '17 at 08:16 PM

Okay, I hate to be that guy, opening up old posts... But that didn't just happen. I can't believe that is the only way to make multiplayer work on a host. Is there any other way to find a LAN game in UE4 without having to disable VBox's Network Adapters in Windows control panel->Network Adapters?

avatar image Jinc Jan 18 '19 at 11:00 PM

Can confirm this fix for my test project in UE 4.21.1

avatar image m_foda May 08 '19 at 01:21 AM

Yup. Confirmed this is what finally worked for me as well with the MutliplayerShootout tutorial on UE 4.22.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question