x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Error:There may be an operating system error or the module may not be properly set up

I am doing a team work with my mates with a version controller. Some mates did some C++ work and when i got latest version, i cannot open it and it said: The game module 'Biclcle' could not be loaded. There may be an operating system error or the module may not be properly set up. I know it may because of losing some relevant dlls but I don't know what are they. How can I check them and fix them???

Product Version: UE 4.11
Tags:
more ▼

asked Nov 10 '16 at 03:17 AM in Everything Else

avatar image

pcjjdy
27 6 15 21

(comments are locked)
10|2000 characters needed characters left

4 answers: sort voted first

I had the same error but it was a different cause, I tried to compile an incomplete blueprint, the program crahsed and wouldn't start up again - it would but it would hang and then show the error message.

I managed to fix it by cleaning and rebuilding the C++ solution in Visual Studio, then closing it after it had finished - it said it deleted old hot-reload files - and running the launcher again in administrative mode.

more ▼

answered Dec 12 '16 at 12:35 PM

avatar image

Sir_Awesomness
13 1 2 5

avatar image Rgtemze Aug 23 '18 at 08:46 AM

Thanks a lot. That worked!

(comments are locked)
10|2000 characters needed characters left

The answer is in this thread. Check the answer from isgoed.

I had the same issues and yeah it's because some dlls can't be loaded (because they don't exists or they are incompatible with the architecture for example)

The previous link helped me to figure out which dlls were missing.

Good luck ! Best regards.

more ▼

answered Nov 10 '16 at 08:19 AM

avatar image

NymKappa
692 31 20 53

avatar image pcjjdy Nov 18 '16 at 06:02 AM

Hi. According to your answer. I have found the dll file which caught the problem. However, I also realized that this dll is in my path: \project\Binaries\Win64\ControlCAN.dll I had it, but it was not included in my project lib. How should I fix it?

avatar image NymKappa Nov 18 '16 at 09:28 AM

Follow this tutorial to know how to link ThirdParty libraries to your project: link text

To simplifie the tutorial, just add two lines in your PROJECT.Build.cs:

 PublicIncludePaths.Add("PATH_TO_YOUR_INCLUDE")
 PublicAdditionalLibraries.Add("PATH_TO_YOUR_LIB/YOUR_LIB.lib")

Good luck :)

(comments are locked)
10|2000 characters needed characters left

in your game folder, open "{your_game_name}.sln" file with Visual Studio, and rebuild the whole solution. alt text

screenshot_1.png (9.4 kB)
more ▼

answered Apr 22 '17 at 12:32 PM

avatar image

Arty-McLabin
838 18 36 57

(comments are locked)
10|2000 characters needed characters left

Hey, I recently ran into this issue when porting my plugin from 4.16 to 4.20.3.

I found that the root cause was that the plugin I had was not setup properly with the right dependent plugins. This meant when my plugin loaded, that it failed to load dlls that it depended on. This caused my plugin fail.. which distracted me from the actual issue that it didn't load all the other plugins it relied on.

Double check that you don't have any plugin warnings when building your plugin (if you built it) and double check the dependencies in the .uplugin file for the plugin that fails to load. This fixed it for me, hopefull for you as well. In my case I forgot to add the 'WebBrowserWidget' plugin.

more ▼

answered Nov 01 '18 at 06:46 AM

avatar image

ambientenergy
11 1 2 5

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question