x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Issue with Cook Content for Windows option

alt text

I was searching for solutions on google for this issue but i was unable to find anything that could help me.It appears in option Cook Content for Windows and without that option some scripts for multyplayer wont work properly.Issue appears in every project and even in templates.I aslo tried to reinstal engine but issue is still there.

Product Version: UE 4.13
Tags:
capture.png (23.3 kB)
more ▼

asked Nov 13 '16 at 10:31 PM in Packaging & Deployment

avatar image

foyline
1 1 1

avatar image navylover Nov 13 '16 at 10:38 PM

The prompt is clear, u may build UE4 project with visual studio, try it and see the issue still exists?

avatar image foyline Nov 13 '16 at 11:04 PM

After trying to generate to Visual Studio project file

Running D:/Program Files (x86)/Epic Games/4.13/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project="C:/Users/Fox/Documents/Unreal Projects/Platformer2d/Platformer2d.uproject" -game -rocket -progress Discovering modules, targets and source code for project... Messages while compiling C:\Users\Fox\Documents\Unreal Projects\Platformer2d\Intermediate\Build\BuildRules\Platformer2dModuleRules.dll: c:\Users\Fox\Documents\Unreal Projects\Platformer2d\Intermediate\Source\Platformer2d.Target.cs(6,14) : error CS0101: The namespace '' already contains a definition for 'Platformer2dTarget' UnrealBuildTool Exception: ERROR: UnrealBuildTool encountered an error while compiling source files

avatar image Matthew J ♦♦ STAFF Nov 14 '16 at 07:48 PM

With that GenerateProjectFiles error, it seems that there may be another project with the name Platformer2dTarget trying to be generated at the same time. Can you ensure that there aren't two projects with this same name and/or including a module with that name?

As navylover mentioned, the solution for this problem would be to compile the project for the appropriate configuration, so getting this GenerateProjectFiles error fixed will be the first step.

avatar image foyline Nov 23 '16 at 02:59 PM

No, there is only one project with that name. What do you mean ''GenerateProjectFiles error fixed will be the first step.''

avatar image Matthew J ♦♦ STAFF Nov 28 '16 at 03:37 PM

I mean that you won't be able to cook properly without being able to generate your project files successfully and thus being able to compile your project, so we should focus on fixing that issue first.

Can you post the contents of your Platformer2d.Target.cs file?

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

We haven't heard from you in a while, foyline. Are you still experiencing this issue? If so, have you tried what I mentioned in my previous comment? In the meantime, I'll be marking this as resolved for tracking purposes.

more ▼

answered Nov 22 '16 at 04:39 PM

avatar image

Matthew J ♦♦ STAFF
31.8k 526 90 417

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question