x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

The global shader cache file is missing

Hello! And sorry for my English!

I have a problem with the launch UE4 game with the following «Targeted RHIs»:

  • DirectX 10 (SM4)

  • OpenGL 3 (SM4)

  • OpenGL 4 (SM5, Experimental)

With «DirectX 11 (SM5)» everything works perfectly. But I need to run the game on the video card without DirectX 11 support (only DirectX 10 or OpenGL). I tried to build an empty project to test run it on the required PC. But I have an error with launch on my PC (Windows 10 with DirectX 11).

I read the similar topics, but did not find the solution for my problem. Please help.


Unreal Editor with Empty Project:

alt text


Packaging settings:

alt text


As I said with «DirectX 11 (SM5)» everything works perfectly. But if I packaged project with other «Targeted RHIs» (without DirectX 11), then I have this message after launch game .exe. If I add this file, the game just don't launch without any message.

alt text

I tried to launch .exe from "WindowsNoEditor/Engine/Binaries/Win64/UE4Game-Win64-Shipping", but I have this message. After packaging game with project launcher nothing is change.

alt text

Product Version: UE 4.13
Tags:
pic (1).png (334.3 kB)
pic (3).png (65.1 kB)
pic (10).png (8.8 kB)
pic (12).png (37.6 kB)
more ▼

asked Nov 15 '16 at 04:18 PM in Packaging & Deployment

avatar image

Nokman
1 2 4 4

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Nokman,

Thank you for submitting a bug report. I have reproduced this issue and logged a report for it here UE-38717. You can track the report's status as the issue is reviewed by our development staff. Please be aware that this issue may not be prioritized or fixed soon.

Thanks!

more ▼

answered Nov 16 '16 at 09:36 PM

avatar image Nokman Nov 17 '16 at 06:17 AM

Thank you for answer! I will be waiting for the solution. Sorry for my English.

avatar image Aliff Nov 16 '17 at 10:14 AM

Hi, i get the same problem..can anyone tell me if this issue has been resolve?and how to do it?thanks

(comments are locked)
10|2000 characters needed characters left

Hi! Same problem for my project. If I uncheck the directX11 the game won't play displaying the uncoocked content error... No one knows how to solve it? Thanks

more ▼

answered Nov 17 '17 at 06:00 PM

avatar image

a.luca
1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question