x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

VR loading splash screen in 4.14

Having trouble getting a VR loading splash screen to work on Vive, it ends up just freezing the current frame and attaching it to my HMD as if that were the loading screen.

In my GameInstance constructor:

 static ConstructorHelpers::FObjectFinder<UTexture2D> SplashScreenFinder(TEXT("Texture2D'/Game/UI/Images/splashscreen.splashscreen'"));
 SplashScreenTexture = SplashScreenFinder.Object;

In my GameInstance::Init()

 UStereoLayerFunctionLibrary::SetSplashScreen(SplashScreenTexture);
 UStereoLayerFunctionLibrary::EnableAutoLoadingSplashScreen(true);

Then I'm testing using "ue4editor MyGame -game", from my hub map, load into another level. Instead of the loading screen, I get a screenshot of my loading level attached to my HMD.

My texture is 1280x1215, no mip maps, B8R8G8A8. Also tried 1024x1024 B8R8G8A8

Am I missing something?

Product Version: UE 4.14
Tags:
more ▼

asked Nov 15 '16 at 10:56 PM in Bug Reports

avatar image

mekaknepley
61 5 6 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Calling SteamVRHMD->UpdateLayerTextures(); inside FSteamSplashTicker::Tick worked around the issue and exposed another crash inside FSteamVRHMD::D3D11Bridge::FinishRendering when RenderTargetTexture is null.

The last frame is never cleared as intended in FSteamVRHMD::RenderTexture_RenderThread, but that never runs when bSplashIsShown for me.

Also, the provided customization options are really limiting. The splash screen is 800x450 no matter what. Offset and Scale just modify the UVs which seems kinda pointless. I can edit the code in FSteamVRHMD::UpdateSplashScreen, but I would rather have parameters to set splash size and position exposed.

more ▼

answered Nov 16 '16 at 03:22 PM

avatar image

mekaknepley
61 5 6 10

avatar image Rudy Q ♦♦ STAFF Nov 16 '16 at 09:52 PM

Hello mekaknepley,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?

  3. Could you provide screen shots of any blueprints/settings that may be involved with this issue?

avatar image mekaknepley Nov 17 '16 at 02:22 AM

I have my workaround and I don't work in clean projects. You should be able to create a C++ project that uses steam splash screens. There are no blueprints involved.

avatar image Rudy Q ♦♦ STAFF Nov 18 '16 at 08:30 PM

I am happy that you have found a work around for you. I will be accepting your previous comment as the answer for this thread. If you require further assistance and/or would like to provide additional information for how to reproduce this issue on our end. Please submit the information in a reply and I will be happy to investigate further.

Make it a great day

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question