x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

VR Vive won't teleport!

So i'm quite new to the blueprint system and i have followed some tutorials on teleportation with VR headsets. I can get VR working within my project (i can walk around, look around, see my controllers etc.), however when i follow any tutorials on getting to teleport with the Vive. It never works, i followed Mitch's VR lab and some other youtubers.

This is how my scene looks like when i test the VR teleport: http://puu.sh/sjXYE/7124ed5e72.png

This is my VR_Pawn1 event graph: http://puu.sh/sjY0j/ce83f18d7d.png

This is my ''Teleport to location'' function: http://puu.sh/sjY1P/e1b1f4109d.png

And this is my ''trace get teleport location'' function: http://puu.sh/sjY3w/e56fa25435.png http://puu.sh/sjY4u/70bdf8a18f.png

I have no idea what i'm doing wrong, if anyone can lend some help by fixing this or giving me a whole different blueprint to teleport that'll nice.

Product Version: UE 4.13
Tags:
more ▼

asked Nov 16 '16 at 08:44 AM in VR

avatar image

PotatoShield
48 7 16 21

avatar image PotatoShield Nov 18 '16 at 10:51 AM

Migrating the ''MotionControllerPawn'' from the VR template project, also does not work. The hands are there, so atleast something is working. But the teleportation doesn't work, even though i have a nav mesh bounds volume within my scene...

avatar image PotatoShield Nov 18 '16 at 10:58 AM

I'm seeing now that the ''MotionControllerPawn'' is giving me compiler errors about input references. Which is weird because this comes straight from the VR template.....

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Teleport got fixed, Only problem is that the teleport indicator that's coming out of my controller does not want to rotate. But i'll close this one as ''SOLVED''.

more ▼

answered Nov 21 '16 at 08:26 AM

avatar image

PotatoShield
48 7 16 21

avatar image mitchellavery Jan 18 '17 at 07:49 PM

Can you explain to me how you fixed this issue? I'm having the same problems with input references

avatar image PotatoShield Jan 19 '17 at 11:57 AM

I used the wrong nodes, the tutorial that I followed used different ones. i figured this out when going into fullscreen and taking a better look at what nodes he added.

avatar image Evolution Of War Jan 17 '18 at 11:50 PM

I'm also trying to migrate the VR Template over to another project, can you explain how you got this to all work, or a link to the tutorial used for this?

avatar image PotatoShield Feb 22 '18 at 03:57 PM

sorry for the late reply, i was "gone" for a couple of weeks. it's been a while since i worked on this project, so i don't remember the tutorial video on youtube. but now you can simply use th VR template from UE4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

VR templates built in UE4, requires NavMeshBounds Volume to work with teleportation - try add this to your level (it has to intersect your floor).

more ▼

answered Nov 16 '16 at 09:50 AM

avatar image

Jacubson
11 1 3

avatar image PotatoShield Nov 16 '16 at 10:06 AM

When i add in a navmesh do i also have to change anything within my blueprints?

avatar image dkoding Nov 17 '16 at 09:46 PM

Add it and let the nav mesh bound volume encompass the area you want nav mesh to be generated on.

Then press 'p' to show the nav mesh generated. It should show up as a green overlay over the navigable areas.

avatar image PotatoShield Nov 18 '16 at 09:36 AM

I placed the navmesh inside my scene and it's green, tested it out and i still can't teleport.

My scene now: http://puu.sh/smgcR/8bf5bdf6a4.png

I think i'll use the VR projec template and migrate that into my project, perhaps that'll work.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I gave up on that and went with mitch's lab simple teleportation blueprint, pretty easy to make and edit and is very frugal too. Might wanna give it a try. Just ignore the navmesh part in the end and go with using normal's of the static meshes.

Good Luck.

more ▼

answered Mar 07 '17 at 09:39 AM

avatar image

ProXit
11 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question