x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.14 Update: No Button reaction to Mouse

Hi there..

Since i updated to 4.14 today, my Buttons of the UMGs are not reacting to Mouseover or clicks anymore..

Is this a Bug or has something changed that i need to Setup?

Product Version: UE 4.14
Tags:
more ▼

asked Nov 16 '16 at 12:17 PM in Bug Reports

avatar image

Chaosgod_Espér
21 2 4 7

avatar image Everynone Nov 16 '16 at 01:06 PM

Noticed this as well.Clicking anywhere outside of the widget makes them no longer focusable and they do not accept mouse over and mouse click events.

edit: Found it!

  1. Go to Edit --> Project Settings --> Input

  2. In Viewport Properties set Default Viewport Mouse Capture Mode to any option that does not capture the mouse permanently.

avatar image Dschadu Nov 16 '16 at 04:31 PM

Thanks, this works for me!

avatar image anderson.rubio Nov 22 '16 at 12:47 AM

Thank you very much! The option "DefaultViewportMouseCaptureMode=CaptureDuringMouseDown" works in my project.

avatar image Tactical_Beard Nov 22 '16 at 11:44 AM

This solves one problem but causes my fps character to lock rotation unless a mouse button is down.

avatar image Czochcio Nov 16 '16 at 01:32 PM

I've updated my projects to 4.14 and have the same issue. All widgets doesnt not accept mouse events. So far i was unable to find a reason why.

avatar image Duddee Nov 16 '16 at 03:45 PM

I'm having the same issue with 4.14. Have to press shift+F1 to re-enable the mouse for widgets. It seems like a bug.

avatar image Czochcio Nov 16 '16 at 03:54 PM

Found the same, Shift+F1 enabled the widgets, but when i click anywhen in the game window it still doesnt receive any event. It looks like when game window is not enabled it receives all the mouse events, but when you click on the game window without widgets it got messy.

What i found in debug mode is that , when you click on viewport and then on widget the router only sends events to Viewport component and not to any widget.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hello Chaosgod_Espér,

After doing a bit of digging I was able to find that this appears to be a known issue. I have provided a link to the public tracker. Please feel free to use the link provided for future updates.

Link: https://issues.unrealengine.com/issue/UE-37698

Make it a great day

more ▼

answered Nov 16 '16 at 03:54 PM

avatar image

Rudy Q ♦♦ STAFF
47.5k 545 132 522

avatar image imsarah Apr 09 '17 at 06:13 PM

it is still not working after shipping (UE 4.14.3)

avatar image Rudy Q ♦♦ STAFF Apr 10 '17 at 01:44 PM

Hello imsarah,

After looking into the issue and running a few tests it appears that the issue on this thread has been resolved. The issue that you are experiencing may be a different issue. Please feel free to create a new thread with more information on how to reproduce the issue that you are experiencing. After that you can post a link here and some one can follow up.

Make it a great day

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Handle the input mode by using the SetInputModeToGameAndUi, SetInputModeUIOnly and SetInputModeGameOnly functions. If you're using a button to close the widget you will have to call the SetInputModeGameOnly Blueprint.

alt text

setinputmode.png (357.4 kB)
aas.png (198.5 kB)
more ▼

answered Nov 23 '16 at 02:25 AM

avatar image

Tactical_Beard
52 3 10 9

avatar image Chaosgod_Espér Nov 30 '16 at 01:54 PM

I can´t get it to work.. My RTS menü was working perfectly before the update.. Now nothing is working anymore.. :/ Is there any tut on how to setup this stuff now?

avatar image Taurian Dec 03 '16 at 04:43 PM

I am having the exact same problem. I'm on the 4.14 tagged branch (Not release). It works in the editor, it works when you package. But if you use a launcher to launch/update the game then you cannot click any widget in the game.

avatar image Tactical_Beard Dec 03 '16 at 06:02 PM

You have to explicitly set the Input mode now, use SetInputGameModeOnly for non mouse stuff and SetInputGameModeUIOnly or SetInputGameModeAndUI for button functionality.

You can find them by right clicking in an EventGraph, turning of Context Sensitive and typing SetInput..

avatar image jimd667 Dec 03 '16 at 08:18 PM

Same issue here, I tried changing the editor input settings for the Viewport properties like the above comments but now my FPS character only moves if I click the mouse down.

I'm not sure if your method is the answer because it hasn't been set as an answered question by other users. For me it almost seems like a workaround until the 4.14.1 patch comes out and fixes everything back (I hope). I noticed there is a case number already out for this but it was updated 2 days ago and it says resolved but i guess maybe they are waiting to release it?

avatar image jimd667 Dec 04 '16 at 01:28 AM

Tactical_Beard,

I'm sorry I ever doubted you, I sat down and implemented this change into my game and it works great. I'll up vote your answer.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question