x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

4.14 Nvidia update physics/traces broken

After try today many things I notice the vehicles work worst than ever, but looks like is not only the vehicles, the line traces looks like in someway are not reporting all correct and the basic physics the same problem, get freezes with substteping etc, tried with this project https://forums.unrealengine.com/showthread.php?88495-The-Re-Inventing-the-Wheel-Thread version 0.4 updated to the 4.14 (need some minimal changes). The vehicles freezes, the other entities no (in a random way) other times after freeze you have to go other app then the engine start to calc physics then the framerate drops, other times after that you're launch to the space at 10000Km from origin or more, where are image glitches...

alt text

Product Version: UE 4.14
Tags:
more ▼

asked Nov 16 '16 at 09:01 PM in Bug Reports

avatar image

Hevedy
638 64 77 115

avatar image Matthew J Nov 17 '16 at 03:59 PM

Hello Hevedy,

As you mentioned, the plugin/project needs changes to successfully build after converting to 4.14, since it was originally made for 4.10. Could you provide that updated version? I would fix these problems myself but I'm also trying to work on finding what's causing the other issue you reported, along with looking into other bugs reported for this new release.

avatar image Hevedy Nov 17 '16 at 04:50 PM

Yeah sure sorry there is: https://dl.dropboxusercontent.com/u/28070491/PublicFiles.7z credits to the original authors. Update the old to the 4.14 with the normal UE4 thing and then replace the files with that ones, and recompile. Note the bug is pretty random, and not sure at this poit if is a code problem of the plugin or engine but the calcs looks like have some kind of problem. When you compile and open the project in the editor you should try about 10 times to see if you get the problem, you have to drive to the cube just after press play in editor viewport keep W pressed all the time until collide with the box (and keep it pressed to see what happen) the problem looks like when the vehicles some of the wheels is in the air and the forward power is applied sometiems freezes the vehicles as in the gif, others work as normal and others launch the car as a rocket out of the engine maps bounds aka about 10000Km out of the map (what don't have logic if is a bug in the project, and looks more like a engine problem) you can try to keep w too and jump in the left side stairs, the bug happen too.

Note in the 4.13 I don't notice this problem.

Tried today to update drivers of the GPU, nothing fix this.

Thanks you.

avatar image Matthew J Nov 17 '16 at 06:02 PM

Can you show me your physics settings for this project, if you've changed any of them? What average FPS are you getting before the collision? I understand that it may be more than what is shown in the GIF as some capture software just captures at a low framerate. I've tried reproducing it quite a bit and haven't only had the freeze occur once, but it was the entire editor, not just the car, for about 3-4 seconds. Other than that, I'm not seeing any issues on my end yet.

avatar image Hevedy Nov 17 '16 at 09:44 PM

I can give you my report, low frames you see is cause if a gif, But I get normal more than 70 all the time this is the other problem: (When the car jump to the space)

alt text

This is my DX https://dl.dropboxusercontent.com/u/28070491/DxDiagNew.txt

And by the way the physics settings and all is included in the file I send you :p

I can give you the complete project too https://dl.dropboxusercontent.com/u/28070491/CarPluginProject_414.7z

avatar image Matthew J Nov 21 '16 at 05:25 PM

Thank you for providing the full project. Did you make any edits to the project itself instead of just the plugin? I wasn't able to get this to reproduce at all in the fresh project with only the plugin, but immediately had this occur with the project you provided.

avatar image Hevedy Nov 21 '16 at 07:32 PM

I just updated the things to work in 4.13-4.14 and added the inputs changes to work with asdw and gamepad nothing more, but in the 4.13 is the same and works fine. I imagine Epic should check the project I send to search the problem there ?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello Hevedy,

I imagine this has something to do with the other issues we've had reported with Vehicle physics for 4.14, although I'm not seeing the same issues on my end so I'm not sure. I believe it may be best to leave this aside until the other issues are fixed and then we can continue looking at this if they weren't related. Please feel free to track one of those issues here: https://issues.unrealengine.com/issue/UE-38710

In the meantime, I'll be marking this as resolved for tracking purposes. If I don't respond after the fix goes in for that or if you have any updates, feel free to leave a reply here.

more ▼

answered Dec 08 '16 at 04:23 PM

avatar image Hevedy Dec 08 '16 at 04:27 PM

I provided a broken sample what other people is able to get the problem, can Epic check the problems and don't mark this as fixed with other non related problems ?

avatar image Matthew J Dec 09 '16 at 06:30 PM

The other issue is causing all sorts of issues completely related to what you are reporting here. I'll leave this marked as unresolved in the meantime but it doesn't mean that I'll be looking at it until the root cause is fixed as there is no reason.

avatar image Matthew J Jan 06 '17 at 10:36 PM

Hello Hevedy,

Have you been able to try this project in 4.14.2 now that the other vehicle issue has been fixed? Do you still experience the same issues? Please let me know and I'll continue looking into this if so.

avatar image Hevedy Jan 07 '17 at 11:08 AM

Well this was more about the chassis box freeze problem and problems with it rater than the traces I think anyway there was other project in the forums about custom cars with the same problem but not tried the 4.14.2 will do when have time.

avatar image Hevedy Feb 05 '17 at 07:09 PM

This is not related with the UE4 vehicles, is a custom vehicle and this is 4.15 even worst this is really sad, this keep broken and no one fix this, I'm using the same project that I provide for 4.14 in the top... https://dl.dropboxusercontent.com/u/28070491/GIFShit.gif

avatar image Matthew J Feb 06 '17 at 06:52 PM

If this isn't based off of the UE4 vehicle system in any way and is completely custom, I can't guarantee that this would work without any edits when upgrading to a newer version, as we have upgraded to a newer version of Phys X.

As with the earlier attempts, I'm still not seeing this behavior. As shown in this video, this is the behavior I see every time I ram into this box, after exactly 50 tries. I've tried with unlocked framerate, 120 fps lock, 70 fps lock (since you mentioned that this was your average), and 60 fps lock and still nothing. I'll need a reliable reproduction to actually look into anything related to this bug report.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question