x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Perspective camera moves erratically after heightmap import

Hello,

I'm trying to import a basic heightmap. After importing, the landscape shows up (a bit stretched, but that may be due to the size being different), however immediately the perspective camera begins to randomly switch between a few different views, one every second or two in a cycle of about 3-5 orientations. I'm running at a very low fps, but even without changing any settings, if I try to zoom out even a small amount it begins this strange behavior.

Thanks.

Product Version: Not Selected
Tags:
more ▼

asked Jun 05 '14 at 01:55 PM in Using UE4

avatar image

vaughnva
86 6 7 10

avatar image Ben Halliday STAFF Jun 05 '14 at 07:50 PM

Hey vaughnva,

Would you mind attaching your heightmap so I can try to reproduce the issue here?

Thanks!

avatar image vaughnva Jun 06 '14 at 12:40 PM

Sure, I was just using an example I found online to see if I could get heightmap imports to work, but here it is: alt text

hm_ex1.png (39.4 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

When I created a landscape from that .png, I didn't get any erratic camera behavior. Does this occur while editing in the Viewport, or only during Play? Does it occur after restarting the editor? Have you upgraded to 4.2 or is this in an earlier build?

Incidentally, that .png also threw a few errors at me when I tried to use it as a heightmap for a new landscape. Apparently the file is not a grayscale png, and it is an 8-bit png as opposed to 16-bit, which is preferred. I don't think that's causing the problem for you, but might be something to consider for future landscaping.

more ▼

answered Jun 06 '14 at 10:08 PM

avatar image vaughnva Jun 10 '14 at 01:39 PM

Ben,

It was on 4.2 - I tried again, but it appears to have resolved itself. The problem may have been that I was previously working at a very low fps.

As to the .png being of the wrong type - it was only a quick example online of something to use, simply to test the feature. I appreciate the warning though.

Thank you!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question