x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Components with an absolute attachment to a MotionController get a late transform update

Reproduction Steps

  1. Create a new empty Blueprint Project

  2. Create a new Pawn class

  3. Set Player 0 to auto possess that Pawn class

  4. add a MotionControllerComponent and attach a Cube to that MotionControllerComponent

  5. In the Cube's Details, set the transformation parameter to type absolute instead of relative (Absolute Location instead of Relative Location etc.)

  6. place the Pawn class in the level and play in VR

Result: The cube moves back and forth, as you move your motion controller

Expected: The cube does not move at all

Possible Fix

add the following line of code at the beginning of UMotionControllerComponent::FViewExtension::GatherLateUpdatePrimitives

 if (Component->bAbsoluteLocation && Component->bAbsoluteRotation) { return; }

Unfortunately this would not fix the problem in a case, where the component's location is absolute, but the rotation is not or vice versa.

Workaround

urrently the only workaround is to detach any Component, that would be attached absolute to a MotionController.

Product Version: UE 4.14
Tags:
more ▼

asked Nov 17 '16 at 05:56 PM in VR

avatar image

AllJonasNeeds
249 26 36 71

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey AllJonasNeeds-

If you select the Motion Controller component there is a checkbox for "Disable Low Latency Update". Its tooltip states "if false, render transforms within the motion controller hierarchy will be updated a second time immediately before rendering." This sounds to me like the behavior you're seeing is expected. If you want to keep the current hierarchy setup, enabling this checkbox will prevent the cube mesh from moving during VR.

Cheers

Doug Wilson

more ▼

answered Nov 21 '16 at 08:36 PM

avatar image MusicHubVR Aug 09 '17 at 03:48 PM

I am still seeing this issue in ue4 15.1, are they ever going to fix this or publish a work around? I am working on my thesis where I am using Vive trackers to track both real musical instruments and a Perception Neuron motion capture suit. I am using one Vive Tracker on the keyboard to establish the initial location, and adding then I am adding a UI button to update the position when needed due to the fact that nothing I do will allow me to track it continuously without jitters. This really isnt a problem for the keyboard, but it is for establishing my tracked characters position. I can't even attach a static mesh to the motion controller without seeing this issue. I have tried disabling low latency update, it still suffers form this issue. I don't want to have to move my project back to Unity this far into the game, and I would much rather use UE4 and I desperately need a solution to this issue. Any help would be greatly appreciated

avatar image Doug E ♦♦ STAFF Aug 15 '17 at 04:48 PM

Hey MusicHubVR-

I tried the steps AllJonasNeeds mentioned in his original post again in 4.15.2. With a mesh attached to the motion controller component in my blueprint, when I enabled the checkbox for Disable Low Latency Update the mesh did not move when using the motion controller. If enabling this setting still causes the mesh to move when moving the motion controller for you, could you provide the full setup steps or a sample project demonstrating the behavior you're seeing?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question