Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Linux] Crash when opening project settings

So, I'm running 4.14 (from the 4.14.0-release tag on git), and if I try to open the project settings window, the editor hangs for a few seconds and then exits. After looking at the log, it seems the engine was trying to launch /Engine/Binaries/DotNet/IOS/IPhonePackager.exe, when it should be looking for /Engine/Binaries/DotNET/IOS/IPhonePackager.exe (notice the incorrect casing on the DotNET directory).

I can work around the issue by creating a symbolic link from Binaries/DotNet to Binaries/DotNET, thus directing the engine to the correct path (the way it is in the git repo), but that's really just a band-aid fix. Since that fixes all references to the wrong path, there could also be other files being loaded using from there.

I find it strange that it's trying to load an iPhone packaging binary on Linux, because you can't package for iOS on Linux and the path normally wouldn't be an issue on OSX since its file system is case insensitive anyway, so maybe the reason that it's trying to load that could be investigated as well?

Here's the last few log entries just before the editor crashes (without the symlink in place):

 [2016.11.16-21.11.13:257][ 37]LogHAL:Warning: LinuxPlatformProcess::AttemptToMakeExecIfNotAlready: could not stat '/home/<user>/UnrealEngine/Engine/Binaries/DotNet/IOS/
 IPhonePackager.exe', errno=2 (No such file or directory)
 [2016.11.16-21.11.13:319][ 37]LogLinux:Error: appError called: Assertion failed: Assertion failed:  [File:/home/<user>/UnrealEngine/Engine/Source/Runtime/Core/Private/L
 inux/LinuxPlatformProcess.cpp] [Line: 857] 
 FLinuxPlatformProcess::CreateProc: posix_spawn() failed (2, No such file or directory)
Product Version: UE 4.14
more ▼

asked Nov 17 '16 at 09:03 PM in Linux

avatar image

6 3 6

avatar image kukiric Nov 18 '16 at 03:42 AM

I just found that this is a duplicate of https://answers.unrealengine.com/questions/524546/linux-opening-project-settings-crashes-editor.html and can be closed. Going to leave this here until someone from Epic staff locks it or confirms the issue, in any case.

avatar image Michael Hart Apr 08 '17 at 07:32 PM

Under Linux version 4.15 the code is doing the wrong thing. the URL is being set to something like "....../Engine/Binaries/DotNET/IOS/IPhonePackager.exe"

When it sould be read as "...../Engine/Build/BatchFiles/Linux/RunMono.sh "....../Engine/Binaries/DotNET/IOS/IPhonePackager.exe" certificates Engine -bundlename "com.YourCompany.PlayerInputs"

Does anyone know were in what file the "RunMono.sh" gets appended

avatar image aknarts Apr 08 '17 at 08:55 PM

Do you have the full log and also what you are trying to do when you get an error? 4.15 does have the above error fixed, which was just plain case of case sensitivity in the path...what you are "describing" is something new(and probably should be in a different thread as this one is solved).

avatar image minsk Dec 03 '16 at 07:15 PM

@kukiric thank you for bringing this up! Helped me as a total linux newb to get the settings opened.

I must have done something wrong with the symbolic link. But manually renaming the folder DotNET to DotNet worked for me.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question