Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blueprint Search Freeze

Tested this on an El Capitan and brand new Sierra macOS box. Happens on not only existing projects, but a brand new project as well.

For whatever reason when I go to add a Blueprint -> Pick Parent Class -> click All Classes the editor completely freezes, I get the spiny ball of death, and have to force quit the editor.

Product Version: UE 4.14
more ▼

asked Nov 18 '16 at 04:24 AM in Bug Reports

avatar image

23 1 2 4

avatar image Steve Hardister ♦♦ STAFF Nov 18 '16 at 03:45 PM

Hi bojo,

Are you running the latest edition of XCode 8?

Have you tried verifying your installation: Launcher>Library>UE4.14.0>YellowDownArrowDropdownMenu>Verify?

Try these and if they do not resolve your issue, please respond and include your Mac's specs.


Steve H.

avatar image bojo Nov 19 '16 at 01:46 AM

Hello Steve,

I ran the Verify option, and double checked that I have XCode 8.1 installed. Unfortunately this still results with the editor hanging.

Specs are as follows:

  • Model Name: MacBook Pro

  • Model Identifier: MacBookPro11,3

  • Processor Name: Intel Core i7

  • Processor Speed: 2.3 GHz

  • Number of Processors: 1

  • Total Number of Cores: 4

  • L2 Cache (per Core): 256 KB

  • L3 Cache: 6 MB

  • Memory: 16 GB

avatar image Steve Hardister ♦♦ STAFF Nov 21 '16 at 08:32 PM

Are the specs listed above for the mac running Sierra? If you open a Blank Third Person Blueprint Project does this happen every time or randomly? Finally, as a troubleshooting step, try deleting the DerivedDataCache folder from the install folder and restart the Launcher/Editor.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

The specs are the same for both machines. I've tried deleting the DerivedDataCache folder based on other info I dug up but no change. I'll give the Third Person project a shot next.

I was able to get around my problem by enabling Show Engine Content in the Content Browser (my goal was to build a GameInstance and SaveGameInstance).

more ▼

answered Nov 22 '16 at 12:51 AM

avatar image

23 1 2 4

avatar image Steve Hardister ♦♦ STAFF Nov 23 '16 at 04:09 PM

I've converted your comment to the answer as workaround for users experiencing a similar issue. I was not able reproduce the issue on the exact model MacBook Pro following these steps:

Create a new Blueprint in the Content Browser as shown below:


Select All Classes in "Pick Parent Class" ass shown below:


...if these are not the steps you are following when the freeze occurs please provide concise repro steps accompanied with screenshots where possible.


Steve H.

cb1.png (77.7 kB)
cb2.png (215.4 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question