x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[BUG] FBX Importer broken (binormals/tangeants)

I already did in the past (with the UDK betas) a long search about this problem, I detailed it in two places : ->Polycount thread and on my blog ->froFBX exporter

Here is my test inside the UE4 :

![fbx_bug_maya2013](/storage/attachments/560-polycount_mesh_fbx_bug.jpg)

As you can see the bug is still here (the mesh named "blender" is correct). From what I know, since Maya 2013 Autodesk changed the way they compute the tangents on their polygonal meshes, which is probably why the UE4 always broke the mesh imported.

This problem also affect the skeletal meshes. If I import a skel mesh and let the editor to compute my normals, I will get a faceted mesh, while if I import my normals I get what I'm expecting (in UE3/UDK my mesh imported was not faceted). Here is the skel mesh if you want to test by yourself : Download "rig_body.fbx".

![skeletal mesh](/storage/attachments/561-fbx_skelmesh_normalsbroken.jpg)


Bug Report:


Build version: 1623704

Install Path: C:\\UDK\\\Rocket\\

Specs: Win 7 x64, 16 GB, GTX 470 (Drivers 301.42), UAC off


--Description : The Editor doesn't read properly the normals/vertices in a FBX mesh exported from Maya 2013 (with the FBX plug-in 2013.1 or even 2013.3) and break the vertices count. (This is also true for Maya 2014.)

--Repro Steps : Download my test mesh (obj file), import it in Maya 2013/2014, export the mesh as an FBX file and import it in the UE4 Editor.

--Expected : The FBX Importer should read properly the vertices count registered by Maya and should import the FBX as it would do with 3DS Max 2012 or Blender 2.63.

--Screenshot : see above for the UE4 bug, see my blog for the UE3/UDK bug.

Product Version: Not Selected
Tags:
more ▼

asked Mar 11 '14 at 03:04 AM in Using UE4

avatar image

ue4-archive ♦♦ STAFF
49.8k 3656 1981 9108

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 03:04 AM

Well I wouldn't say the importer itself is broken. If I set it to import normals the model always imports fine. However if I set it to calculate the normals I get a faceted mesh. I am using 3DS Max 2013 and it is the same situation. So maybe it would be better to make the import normals the default option, rather than recalculate normals.

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 03:04 AM

Well, I say it's broken because with the UE3 editor, if you import a mesh and let the engine to compute the normals, it gives you normally a mesh with one smoothing group (averaged normals), while with meshes created with Maya and now with the last FBX version (both Maya and Max) it breaks all the normals and gives the faceted look.

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 03:04 AM +

Yes the calculate the normals option is broken. However you made it sound a bit like importing normals is broken too. ^^ Especially since the repro steps don't mention changing the setting to calculate the normals. Anyway I get what you mean now, and I got confused when importing my first model as well.

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

I don' think the calculate normals option is broken. Calculate normals uses smoothing groups to find faces that are smoothly connected. The file you provided has 0 for the smoothing group in each triangle which is not a valid smoothing group (Smoothing groups much match at least one bit in a binary AND or else they arent connected. 0 & 0 is still 0). Please note that Maya doesn't use smoothing groups so when you import into Maya it recalculates the normals differently which is why it looks correct in maya. I also have tested this in UE3 and it functions the same way and the mesh comes in faceted. The large vertex count difference is because we cannot share any vertices across triangles when every edge is a hard edge. In this case you get 3 unique vertices per triangle.

I've seen this happen when importing OBJ files without smoothing groups into Maya. Once I export your mesh again with the "geometry->smoothing groups" option checked in the maya exporter dialog, it comes in fine.

more ▼

answered Mar 11 '14 at 03:04 AM

avatar image

ue4-archive ♦♦ STAFF
49.8k 3656 1981 9108

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 03:04 AM

That's strange, I always had the option "Smoothing Groups" enabled in my FBX exporter. I can guarantee that my meshes are fine under Maya. I'm also not the only one that get this problem. (Also I don't import meshes in Maya, I create them from scratch in Maya and export them as FBX file.)

My export options are : Smoothing groups enabled, Split per-vertex normals disabled, Tangents and Binormals Enabled, Triangulate enabled.

I have tested it again and I get a wrong polycount. If the fault is on my side I apology, but I checked again and again, something is probably missing in your explanation I guess.

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 03:04 AM +

I did a new series of tests to be sure. I fixed the problem on the "x letter" mesh (it was my fault, under Maya I forgot to soften the normals), however I have an other mesh that is not working correctly.

The second mesh is a multi-material mesh, under UE3 it gave mesh 9930 vertices if the mesh comes from blender, while I get 12267 from Maya.

With Rocket I get a little change, but there still a difference of polycount : 10796 vertices form Blender, 12834 from Maya 2013.

I used the same export options as above, I checked to be sure that my normals were soften and locked in Maya before exporting. I don't understand why I get this difference.

[download test mesh](/storage/attachments/562-test_caravan.zip)

![alt text](/storage/attachments/563-ue3_mesh.jpg)

![alt text](/storage/attachments/564-ue4_mesh.jpg)

test_caravan.zip (806.8 kB)
ue3_mesh.jpg (13.3 kB)
ue4_mesh.jpg (109.2 kB)
(comments are locked)
10|2000 characters needed characters left

For the difference in vertices I'm guessing that Blender is just welding some vertices together, which your Maya isn't doing by default?

more ▼

answered Mar 27 '14 at 10:10 AM

avatar image

animal531
1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question