Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Master sequencer or Shots do not play in 4.14

Hi, I created a level sequence, added a camera cut track and camera, adjusted as usual, all works fine. Created several of these. Point is CameraCut tracks play in view port. Problem is Shottracks do not.

I create a master level sequence or use the create Master sequence along with shots and folder settings.

None of this plays in the view port or in-game within 4.14.

It seems there is a bug preventing playback of master sequence or specifically shots tracks in general within 4.14.

Testing in 4.13 all works fine. please fix.

Oh a side note, Please fix camera tracks so it always be locked to specific view port no matter what options available. I find extremely annoying after locking to view port it disable when doing other operations. Have it permanent locked to view port until i pressed unlock manual. thank you look forward to response.

Product Version: UE 4.14
more ▼

asked Nov 19 '16 at 08:53 PM in Bug Reports

avatar image

46 2 6 7

avatar image Matt.Williams Nov 23 '16 at 09:03 PM

So you'll still need Camera Cut tracks in each shot so it knows what camera to use. Are you doing this?

avatar image Architect3D Nov 23 '16 at 09:45 PM

Yes tried everything for an entire day. Tried Camera Cut tracks over shot tracks within the master, each shot has a camera cut within otherwise it wouldn't play as mentioned above. The thing is the exact same setup works in 4.13. it doesn't work in 4.14. unless something has changed with how to use sequence editor for 4.14, I just think its a bug.

avatar image Matt.Williams Dec 01 '16 at 07:11 PM

Can you send me an example project? I'd like to see this first hand. You can PM me a download link on the forums.

-Matt W.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi, this issue is valid and happens in my project as well. We have tons of sequences made pre 4.14, and today we finally switched to 4.14. We use a lot of sub sequences in master sequences and the camera cuts just stopped playing completely. After tinkering a bit in the code I found the change that caused this to happen:

LevelSequencePlayer.cpp - Line 490

UE 4.13

 if ((CameraObject == nullptr) && (UnlockIfCameraActor != ViewTarget))

UE 4.14

 // if unlockIfCameraActor is valid, release lock if currently locked to object
 if (CameraObject == nullptr && UnlockIfCameraActor != nullptr && UnlockIfCameraActor != ViewTarget)

After reverting this condition to the way it was in 4.13 everything works perfectly fine again.

Since it already works for us I didn't dig dipper into the problem and accept my solution the way it is. However my assumption is that sub sequences not having camera cuts revert the camera to previous state by calling:

MovieSceneCinematicShotTrackInstance.cpp - Line 70

 if (TraversedSections.Num() == 0)
     Player.UpdateCameraCut(nullptr, nullptr);

And as you can see in the earlier conditions I posted in 4.13 the UnlockIfCameraActor was not null verified so the function just returned doing nothing making the master sequence camera cut not interrupted.


more ▼

answered Jan 03 '17 at 10:09 AM

avatar image

33 5 11 16

avatar image Architect3D Jan 03 '17 at 10:25 AM

Hey Marek, Thanks for the update. And I appreciate you posting the solution. I don't know anything about code, so I hope Unreal Devs will add this to their fix log for next update. I maintain using 4.13 for now. thanks again.

Have a great new year

avatar image Matt.Williams Jan 04 '17 at 09:16 PM

Hi Marek,

Could you provide an example project for this issue? It'll get fixed a lot faster if I can enter a bug report with solid repro steps. I've been unable to get this to happen.

-Matt W.

avatar image Marek Jan 05 '17 at 08:39 AM

Hello Matt,

Since it is already fixed on my end, it's not the highest priority for me at this moment and as much as I would like to be of help, we're currently crunching till the end of the project so I have tons of stuff to work on. However if I find the time to figure out a repro I'll let you know.


avatar image Matt.Williams Jan 09 '17 at 08:55 PM

I'm going to mark this as resolved for tracking purposes. If you do get any free time, feel free to enter a pull request on github. That might be the quicker solution if you don't have time to make a project.

You can respond here to re-open the thread.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Architect3D,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

-Matt W.

more ▼

answered Dec 13 '16 at 06:35 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question