x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

[BUG REPORT] Text and materials not showing correctly and some other render issues on Android 6.0 and 4.4.2

Hi! Something similar has occurred to me in the past

But now in 4.14.0 in Android ETC1 with text appearing just as "blocks", and also my target in the middle of the screen now has no alpha, its the same one found in the FirstPersonTemplate, and yes I had tested it and it appears black too.

alt text

Sometimes, that material with the title of my game "Virtrin" appears just as a black material randomly, like in my previous report. alt text

My cellphone is a Huawei G Play Mini with Android 6.0 and a ARM Mali 400

And then I proceed to test in other phone, and things got worst.

Now this time with a Lanix Ilium S130 with Android 4.4.2

alt text

UMG Elements and text appear correctly...

alt text

But the 3D environment don't. It has too much contrast.

If you see, things that look bad in Android 6.0 look good in 4.4.2 and vice versa.

I hope this gets fixed, since my project is aimed for devices from 4.4.2 to 6.0 Thank you!

Product Version: UE 4.14
Tags:
more ▼

asked Nov 20 '16 at 07:37 PM in Bug Reports

avatar image

FernandoDev
1 3 5 7

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

So your main issue is that the size of your texture exceeds the mobile limitations. The dimensions of the texture in question are 3556x2000 and the maximum we allow in any direction is 2048x2048. I would be sure to take a read over the Texture and Performance Guidelines for mobile as the will definitely come into play while developing.

With that said, I was still able to get the single texture to render correctly in your project when launched to and Android device using the ASTC compression which is the latest form of compression.

Texture Guidelines for Mobile

Android Device Compatibility

As you can see if you looked at the device compatibility, the GPU family you are testing is the least tested and most uncertain of devices in regards to what is expected to work on devices using those gpus.

Samsung Galaxy Note 10.1

alt text

Samsung S3 - Mali 400

alt text

Your targeted hardware was also set to Desktop/Console so that could also have an effect on the final packaged project. I am aware this device has a different and newer GPU compared to the one you are testing and I will test that GPU as soon as I have the correct device.

Thank you,

Andrew Hurley

mali400.png (282.3 kB)
more ▼

answered Dec 06 '16 at 08:14 PM

(comments are locked)
10|2000 characters needed characters left

Hello Fernando5567,

I ran some tests on my end, and am not getting the same results as you are reporting. Granted, I launched to a Samsung S5 and tested the default First Person Shooter Example template project. You mentioned you get the same results when testing the FPS template project which makes me think this could be related to your device.

I do have a suggestion which could be the cause of your issue. In your materials that you are calling to draw to the screen, be sure their domain are set to UI and any associated textures are within the UI texture group. Below are the results for my test example map.

UI Material Domain alt text

Captured on Device - Samsung Galaxy S5 alt text

Let me know if you have further questions or additional comments.

Thanks,

Andrew Hurley

more ▼

answered Nov 21 '16 at 09:37 PM

avatar image FernandoDev Nov 21 '16 at 10:11 PM

Hi! I changed the domain and the nodes exactly as you shown and the material again shows black randomly. alt text

Please also note that the text showing the FPS still shows as blocks.

By the way, I fixed the target alpha by changing the blend mode to Masked. alt text

I think both problems, the materials, the text and that the game appearing too shiny are device specific in my case, but they both use generic components (very predominant in my region) so I think if this is solved It could be solved in other devices too.

Thanks for your reply! P.S: Yes, in my previous report the problem was specific with my cellphone's CPU and GPU, but it got solved around 4.11.x... and now it's back haha

avatar image AndrewHurley Nov 28 '16 at 10:17 PM

Can you provide me with a test project so I can replicate what you are experiencing?

I have been unsuccessful thus far in reproducing your issue on my end, so I need some concrete ways to get it to appear on a device we have here.

Let me know if you have additional questions.

Thank you,

Andrew Hurley

avatar image FernandoDev Nov 30 '16 at 09:55 PM

Hi!

Here's a test project. with the material and the mesh exactly as how I am using it.

Screenshot: alt text Remember, this happens randomly.

Also, if possible fix the text and the materials showing too "shiny" on certain devices :(

PS.: The material is in the Surface Domain because if you change it to UI Domain the material won't even show up. I found this strange now since I tested it previously (in my later reply) but the same problem happened; The material shows black.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question