x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Particle Parameters for Initial Location

I am trying to make it easy to resize my particle systems, but am struggling to do so.

In this example, I have setup a particle system that spawns some white specks. In its initial location module, I set the distribution to a vector parameter called Initial_Location.

alt text

Next, I dragged the system in my map, and I setup that Initial_Location to a random vector between 0 and 300 on all axes.

alt text

However, the particles simply seem to spawn at 0, 0, 0 and then spread out. Regardless of what values I use, this stays the same. (I tried really large values such as 100000 as well.)

What am I doing wrong here?

Product Version: UE 4.13
Tags:
1.png (79.0 kB)
2.png (66.4 kB)
more ▼

asked Nov 21 '16 at 03:16 AM in Blueprint Scripting

avatar image

bobdeschutter
48 1 4 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

May it be because the Min and Max (input and output) on your Distribution Particle Parameter on the cascade editor are set to 0/1?

more ▼

answered Feb 01 '17 at 12:29 PM

avatar image

Mighty Marcos
106 6 9 15

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

You're right. Thanks so much! I thought the min and max were relative and not absolute. I put two pictures in attachment on how to set this up in case it helps someone else.

1.png (67.7 kB)
2.png (333.9 kB)
more ▼

answered Feb 01 '17 at 07:59 PM

avatar image

bobdeschutter
48 1 4 5

avatar image Mighty Marcos Feb 02 '17 at 02:06 PM

I've lost a lot of time with this issue when I made scalable particle systems for Tower Princess. I'm glad it helped you! :D

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question