x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Print String not working

For some reason, the print string nodes are no longer printing to the screen. If I press ` twice I can see the prints by opening the console in the PIE, but the UI for that covers the entire game and its annoying to do it every time.

This happened after I was playing in the editor, and I did some weird order of keystrokes that had a bunch of stats and other logs open in the PIE that covered nearly all of the top left screen. I wasn't sure what it was so, I pressed the same keys, more or less, and it went away, but after that, I can't view the normal logs.

Is there some sort of a short cut I used to toggle the viewing of these logs, or something?

Product Version: UE 4.14
Tags:
more ▼

asked Nov 21 '16 at 10:43 PM in Using UE4

avatar image

Willard720
298 14 24 54

avatar image sloppyjava Nov 22 '16 at 06:22 AM

The same thing happened to me after using AI gameplay debugger. disabling it in project settings got print strings working again for me, although now I can't debug AI visually. seems like a bug to me.

avatar image sloppyjava Nov 22 '16 at 06:27 AM

I'd like to add that (for the moment at least) after re-enabling the plugin, print strings are still working. even after toggling the AI debugger off and on again in PIE (with the apostrophe key).

avatar image Susseroase Jan 03 '17 at 03:42 AM

Williard did you get it to work? I'm still having trouble

avatar image Los313 Jan 17 '17 at 01:20 AM

I'm having the same problem. Turned AI gameplay debugger and print strings stopped printing, but when I turned Ai gameplay debugging off, my print srtings still won't print.

avatar image Willard720 Jan 17 '17 at 11:18 AM

I'm sorry, I did eventually get it to work, but it was so long ago, I forgot. I'm not even sure which project it was on. I check around but they all had it working. I suppose the most brute force/last resort work around is to create a new project and reimport all the assets. Sorry guys :/

avatar image shotty46290 Jan 17 '17 at 11:41 AM

it's ok you probably hit the ' button which opens the basic info data and turns off your print strings, but when its on there is a list of commands above it and you can have them on while basic data is open.

avatar image Willard720 Jan 17 '17 at 09:23 PM

I'm pretty sure that wasn't working, which is why I posted this question.

avatar image Dealman Jan 17 '17 at 10:31 PM

I can confirm that this is a bug in 4.14, however I can not seem to find any steps to reproduce it. But I can not have a single session longer than 30 minutes without Print String "breaking" in the entire project.

The only fix I know of is to restart the editor entirely. This is probably the most frustrating bug I've encountered in UE4 thus far :(

(comments are locked)
10|2000 characters needed characters left

4 answers: sort voted first

Go to "Editor Preferences.." and click "Reset to Defaults" button, then close the editor and restart it, and it's ok. alt text

alt text

more ▼

answered Feb 20 '17 at 11:29 AM

avatar image

jspzyhl
55 1 6 7

avatar image Willard720 Feb 20 '17 at 11:43 AM

Yup, this did the trick.

avatar image caleb.tenebrous Jul 11 '17 at 10:39 PM

It's still broken for me. I've combed the internet for 4 hours now looking for fixes but no matter what I try, I can't get messages to appear on screen or in the output log.

avatar image Fredrum Aug 20 '17 at 08:01 AM

Hi did you figure out how to get the messages back? I'm having the same problem.

avatar image Dealman Aug 20 '17 at 03:56 PM

Last few times I was encountering this issue it was related to my level blueprint. I had to make a new one and it would work again for that level.

I've used PrintString quite a lot to debug my code, but as of late I barely use it at all it's just far too buggy and seemingly no effort is being put into fixing them as of yet.

avatar image Fredrum Aug 20 '17 at 06:57 PM

Ok thanks. For me it's not related to the level as I can start a new map/level and the problem is still there. Its agonizing as it is my main tool of debugging, im doing a networked game and it means that many things I have to test running on two computers and that rules out the in-editor debug tools. I don't understand why they don't spend some time fixing it. I mean come on, 'Print' should just work.

avatar image Dealman Aug 20 '17 at 07:34 PM

Other than the levels the only thing that comes to mind was PrintString being bugged when you used the Gameplay Debugger. Whenever that happened I don't think I was ever able to find a way to fix it other than to start a new project.

I agree it's incredibly annoying. It's easy to think a lot of stuff 'should just work' but sadly this isn't the case a lot of the time.

Really all we can do is try and find a way to reproduce it, note it and submit a bug report. I too find it rather peculiar how this has been around since like 4.9 or so - personally I think it's rather despicable how little attention it's been getting but they might have other bigger priorities.

avatar image Fredrum Oct 04 '17 at 08:44 PM

I think I have just figured out what caused the problem for me after about 6 months of pain! Just now I started doing some clearing up of all the error messages and warnings I was getting in the Output Log and once that was all pretty much cleared up the Print (to screen) messages all started to appear again! I'm wondering if there's some kind of limit I was hitting where all my errors and warnings were blocking up the Print printing? That might be something for other people to check too if other things don't work.

avatar image TorQueMoD Mar 16 '18 at 10:58 PM

Reset to defaults is greyed out and none of the other solutions fixed it for me. Rather frustrating.

(comments are locked)
10|2000 characters needed characters left

For all those who are experiencing this issue, what fixed it for me was typing "EnableAllScreenMessages" in console while in-game or you can use an execute console command node somwhere on beginplay in an actor you use in your level.

more ▼

answered Sep 19 '17 at 04:22 PM

avatar image

WixZ
76 2 12 11

avatar image Fredrum Sep 19 '17 at 04:43 PM

Tried that. Does not work unfortunately in my case. Also in my case it was working for one actor but not for others.

avatar image krishcrush_ May 25 '18 at 09:30 AM

This worked for me. Some of you might be having this issue because you used the 'DisableAllScreenMessages' command at some point. I did what @wixz said and it solved the issue for me.

(comments are locked)
10|2000 characters needed characters left

Maybe it's because you did not put the blueprint on the viewport alt text

more ▼

answered Jan 28 '18 at 04:30 PM

avatar image

ARGAMES 47
0

(comments are locked)
10|2000 characters needed characters left

Just ran into this, and it also didn't fix itself when I reset my editor preferences. I was able to cheat my way around it in visual studio.

In UnrealEngine.cpp, there's a function:

 void UEngine::Init(IEngineLoop* InEngineLoop)
 {
     ...
 
     if (GConfig)
     {
         bool bTemp = true;
         GConfig->GetBool(TEXT("/Script/Engine.Engine"), TEXT("bEnableOnScreenDebugMessages"), bTemp, GEngineIni);
         bEnableOnScreenDebugMessages = bTemp ? true : false;
         bEnableOnScreenDebugMessagesDisplay = bEnableOnScreenDebugMessages; // Force these to TRUE
 
         GConfig->GetBool(TEXT("DevOptions.Debug"), TEXT("ShowSelectedLightmap"), GShowDebugSelectedLightmap, GEngineIni);
     }
     ...
 }

If you force the values of bEnableOnScreenDebugMessagesDisplay and bEnableOnScreenDebugMessages to TRUE while starting up the editor, it clears out the issue so you can launch normally.

Still not sure what breaks it, but wanted to share the workaround.

more ▼

answered Sep 15 '17 at 11:57 PM

avatar image

John.Swift4
1 1

avatar image Fredrum Sep 18 '17 at 03:38 PM

Very cool thanks a million for sharing John! This is such a stupid and annoying problem and Iv'e had it for a loong time now. In my case I figure out that the print still worked with one particular Pawn but not with the others. So now I have a custom print function on that Pawn that I call instead. So I have to message pass to it for every Print. Silly but it seems to work mostly. But your fix is easier to work with so I will save this link and if things go too bad I know how I can move forward! Cheers, Fred

avatar image TorQueMoD Mar 16 '18 at 11:00 PM

Where do you locate UnrealEngine.cpp?

avatar image TorQueMoD May 25 '18 at 05:49 PM

Yeah, I had disable all screen messages set in the level bp on begin play that I forgot about cause I was taking screen shots and didn't want to re-bake lighting. :)

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question