x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Standalone works but packaged build has fatal startup error

I can't seem to figure out why my packaged build does not run. Immediately on startup an error box appears saying "fatal error" with no other information. I've tried fresh builds with both development and shipping configurations, both with the same result.

Product Version: UE 4.13
Tags:
more ▼

asked Nov 22 '16 at 06:44 AM in Packaging & Deployment

avatar image

HuntaKiller
160 10 12 19

avatar image Samantha Sutton ♦♦ STAFF Nov 22 '16 at 10:24 PM

HuntaKiller,

In order to better assist you, we're going to need some output logs. Please upload them as a .txt file.

Thank you!

avatar image HuntaKiller Nov 22 '16 at 10:57 PM

What output logs would you be talking about? As I mentioned it simply crashes with "fatal error" and no other messages or logs.

alt text

There is one text file in the packaged folder but it is created when packaged, not after runtime.

link text

avatar image elliotENGi Nov 23 '16 at 01:47 AM

You can find the log for packaged game here: WindowsNoEditor/ProjectName/Saved/Logs

I've run into an error like this once before and it was caused by some random broken cached blueprints or something of the sort. Removing the intermediate and saved folders to refresh the project fixed it from memory.

avatar image HuntaKiller Nov 23 '16 at 03:17 AM

When I package the project I can see it referring to assets that have since been renamed or deleted, and I did delete all the folders except source, content, and config, and rebuilt from there, but I'll try again.

Regarding the logs, are they in a different folder than the packaged project folder? because after running the project there are no other folders or temp files being created, under WindowsNoEditor/(my project) there are only Binaries and Content folders. Are they stored locally but in a different directory than the packaged project?

avatar image Samantha Sutton ♦♦ STAFF Nov 23 '16 at 08:43 PM

The logs should reside in the Saved > Logs folder. Also, if you're noticing that the naming conventions haven't changed, you might want to delete your Intermediate and Saved folder (after you've gotten the logs out) to see if that helps any.

avatar image HuntaKiller Nov 26 '16 at 12:29 AM
  1. I delete all folders except for Source, Content, and Config

  2. I right-click my project and click Generate Visual Studio Project Files

  3. I open the project, it tries to build but fails due to a missing file /Build/Windows/Application.ico so I create that directory and get that file from a different project. Project now builds and opens

  4. I set up the packaging settings (Shipping, Full Rebuild, Use Pak, Include Pre-Requisites)

  5. Packaging completes successfully, but still gives warnings that it is looking for files I have deleted (LogLinker: Can't find file '/Game/VladOcsModels/Updated/new/first-sword-with-controls-1_1_Latest') a file and directory that does not exist

  6. Packaged game crashes at runtime with "fatal error message", there is no Saved Folder in the packaged folder but the Log from the project folder is 7.5 MB and can be found here

The crash occurs when built in both development mode and shipping mode

The output also gives me warnings that don't show up in the editor (Warning: [Compiler AITASK_Worm_BurrowBasedOnDistance] Warning 'Enemy Worm' does not inherit from 'Enemy BP' ( K2Node_DynamicCast_775 would always fail).) when Enemy_Worm DOES inherit from Enemy_BP

avatar image HuntaKiller Nov 26 '16 at 01:34 AM

Okay after the rebuild in Development mode it has now created a log in the packaged folder (but doesn't create such a log when built for shipping which is why I was confused before). My log for the packaged version is attached here

I actually had it working yesterday that's why I had the slow response, but apparently I broke it since then. One of the things I did was change the startup map so I'm going to try a few more things. I'm also going to build with the crash log included as hopefully that will give me more inf

link text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I ended up solving the problem. My MainMenu map was causing the crash. When I exported only my testlevel and set that to the startup-level, I was able to run it.

I created a simple empty level and tried that with my menu and it worked, clearly something in my test level was causing the crash.

Basically if you encounter a problem such as this try to slowly cut out everything that could be causing the problem. Start with an empty level only, then try one of your levels, if the empty one works but not your level then it's something in the level causing the issue.

If someone can still comment on the weird warnings I'm getting it'd be appreciated.

more ▼

answered Nov 26 '16 at 04:37 AM

avatar image

HuntaKiller
160 10 12 19

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question