x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blueprint runtime error accessed none.

I've created a simple chat system from a tutorial but I can't figure out how to fix this bp runtime error :/ It affects the chat badly as if i press to chat i can't go back to main game and keep playing if I've already pressed 'T' For Talk on chat. Any Ideas? Thanks! Screenshots: http://imgur.com/a/rWaRm NijoMeister alt text

Product Version: UE 4.14
Tags:
more ▼

asked Nov 22 '16 at 04:52 PM in Blueprint Scripting

avatar image

NijoMeister
70 9 10 16

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

This error means that one of your variables hasn't been initialized by the time you try to access it (Maybe the HUDClass variable in your screenshot). There are many causes for this, but one thing I always do is put an IsValid BP node in front of every variable access if there is a chance it could be "None" (NULL). That will make the error go away, but probably won't fix your underlying issue.

more ▼

answered Nov 23 '16 at 09:21 PM

avatar image

Dartanlla
2.6k 62 26 281

avatar image NijoMeister Nov 24 '16 at 03:52 PM

I've added the IsValid Node and the error goes away but it didn't fix the problem unfortunately because It keeps returning as not valid. Any ideas on what may cause that not coming up as valid?

Thanks! alt text

untitled.png (403.1 kB)
avatar image Dartanlla Nov 25 '16 at 01:08 AM

Where is the code that sets the HUDClass? It looks like the value is not set prior to where you are trying to read the value. This isn't that surprising since you are trying to read it in the Constructor.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question