x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Updating from 4.9 to 4.14 with 2015 Community I get a No 32 bit error

After installing VS 2015 Community I get this error when trying to create a blank project. or convert an old project...

An error occurred while trying to generate project files.

Running D:/Epic Games/4.14/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project="C:/Users/kevin.mitchell/Documents/Unreal Projects/SilverLineSystem/SilverLineSystem.uproject" -game -rocket -progress Discovering modules, targets and source code for project... UnrealBuildTool Exception: ERROR: No 32-bit compiler toolchain found in C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin\cl.exe

Product Version: UE 4.14
Tags:
more ▼

asked Nov 22 '16 at 09:33 PM in Bug Reports

avatar image

Shoiko
638 57 55 67

avatar image Shoiko Nov 22 '16 at 09:35 PM

Installer version: Visual Studio Community 2015 with Update 3 – Free

avatar image GenXu May 18 '18 at 07:13 PM

I solved this error like this: 1. Repairing Visual Studio 2017 2. Uninstalling and reinstalling completely Unreal Engine.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I also ran into this prroblem these days. But finally I found out VS2015 don't have C++ language as default. I just set up VS 2015 again and select C++, and then all works. Hope this could help.

more ▼

answered Nov 22 '16 at 11:46 PM

avatar image

hmskyijun
121 2 9 13

avatar image Shoiko Nov 23 '16 at 12:35 AM

Ill try this in the AM thx

avatar image Jared Therriault Nov 23 '16 at 01:03 AM

This was my solution a couple days ago too. This is the answer.

avatar image Shoiko Nov 23 '16 at 01:25 PM

worked ! thx

avatar image CometGoat Dec 11 '16 at 06:41 PM

I was lazy and didn't want to reinstall VS, so I looked here: https://msdn.microsoft.com/en-us/library/60k1461a.aspx

You can install the C++ tools by attempting to make a new C++ project. It looks like this:

alt text

Thanks so much for the answer!

installc++vs.png (65.1 kB)
avatar image Janitorus Dec 01 '17 at 08:19 AM

Yep, this solution worked. Thanks!

avatar image Markhoss Mar 05 '18 at 03:15 PM

CometGoat how did you get the option to show Install Visual C++ 2015 I tried just about everything but nothing works I don't have this in my VS.

avatar image Tananger Apr 21 '18 at 11:10 AM

Thanks CometGoat, you saved my saturday coding morning! ^^

avatar image rasamaya Jan 29 '17 at 05:38 PM

If you still have the VS installing kicking around then launch, and choose modify, the C++ module you need to check is pretty much at the top of the list. So no need to re-install anyhow.

avatar image Studio Kubuz Feb 07 '17 at 11:42 PM

Thanks! Saved my day

avatar image Inquisitha Apr 05 '17 at 12:14 AM

Saved my hide as well, cheers!

Just don't forget to restart your computer after modifying VS.

avatar image Jamesdaley121 Jun 16 '18 at 03:02 PM

I recently encountered this error when trying to package to windows 64-bit. Following this managed to remove the error and I packaged successfully. Thank you very much.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
more ▼

answered Apr 25 '17 at 10:36 PM

avatar image

Raistlin_Majere
66 2 4 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question