x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Selection issue 4.2

Some models cannot be selected with click and drag. This worked fine in 4.1.1. Why doesn't it work anymore?

Product Version: Not Selected
Tags:
more ▼

asked Jun 05 '14 at 08:31 PM in Bug Reports

avatar image

deathclonic
60 10 17 18

avatar image Ben Halliday STAFF Jun 05 '14 at 08:43 PM

Hey deathclonic,

Can you be more specific? Where are you trying to select these models, the Level Viewport or a sub editor? What type of models, just Static Meshes? By "selected with click and drag" do you mean doing a marquee selection? Thanks!

avatar image deathclonic Jun 05 '14 at 08:46 PM

They're just basic wall models. All I did was place them in the level and started moving them around and then I tried to drag select and it does not select them. It works in the 3D viewport but not the 2D viewports.

avatar image deathclonic Jun 05 '14 at 08:56 PM

More complex models can be selected.

avatar image Ben Halliday STAFF Jun 05 '14 at 09:04 PM

Are the models that you can't select Static Meshes that were converted from BSPs?

avatar image deathclonic Jun 05 '14 at 09:15 PM

No they were created in maya to be used modularly and exported as .fbx.

avatar image Ben Halliday STAFF Jun 05 '14 at 09:21 PM

Okay, what I'm seeing so far is that if I create a mesh from a BSP brush in 4.1.1 and then convert that project to 4.2, I can no longer marquee select it in the Top, Side, or Front viewports. That's definitely a bug. I am not seeing the same behavior when I import a custom mesh, however.

Would you mind zipping and attaching a test asset with which this bug occurs in your project? I'd like to make sure we figure out what's going on here. Thanks!

avatar image deathclonic Jun 05 '14 at 09:30 PM

That might explain it actually. Because I made a template map back in 4.1.1 and converted it when I got 4.2. I did try reimporting the assets but that did not solve the issue. Here's some samples https://dl.dropboxusercontent.com/u/67848802/Models/EX_128x32.uasset https://dl.dropboxusercontent.com/u/67848802/Models/EX_256x32.uasset https://dl.dropboxusercontent.com/u/67848802/Models/EX_384x32.uasset https://dl.dropboxusercontent.com/u/67848802/Models/EX_512x32.uasset

avatar image Ben Halliday STAFF Jun 05 '14 at 10:02 PM

So these assets were originally created in Maya?

avatar image deathclonic Jun 06 '14 at 02:40 AM

Yes. Sorry about the delay I had work.

avatar image deathclonic Jun 16 '14 at 01:48 AM

I really hope this issue gets resolved in the next update.

avatar image master_rigel Jul 06 '14 at 06:22 AM

I'm going to stop using UE4 until the selection issue gets fixed. There's no way to select objects reasonably in the scene outliner without naming every single object during prototyping, and I can't select things like walls and floors in orthographic view, becuase they have only 12 tris, and I can't do marquee selection in perpsective view, so the editor is useless to me. I'm cancelling my sub until this gets fixed.

avatar image Ben Halliday STAFF Jul 07 '14 at 08:11 PM

Hey master_rigel,

I am sorry that you're having a difficult time with the feature not working correctly, and I certainly understand if you feel unable to use the editor until it is fixed. I can tell you that the bug is being tracked in our database and our developers are working to fix it.

In the meantime, if selecting your assets in the scene outliner is not feasible workaround in your project, you can marquee select in Perspective view. Hold Shift+Ctrl+Alt and drag with the left mouse button to create a marquee box. The bug that prevents certain objects from being selected in Orthographic views does not effect Perspective, so you can grab anything in your scene this way.

Again, I apologize for the inconvenience, but I hope the Perspective marquee select feature will help you continue to use UE4 until the bug is fixed. Thanks for your patience!

Ben Halliday

avatar image master_rigel Jul 07 '14 at 08:45 PM

Thanks. I didn't know that. It's not ideal, but it's "enough" to get me by.

Regards, Rigel

avatar image Ben Halliday STAFF Jul 07 '14 at 08:48 PM

Glad to hear it! I will update this thread as soon as I see there's been a fix.

avatar image deathclonic Jul 11 '14 at 09:41 PM

Ok so I got the 4.3 preview and this issue still persists. The only way I can marquee select is with meshes that are more of a rounded shape or have been rotated in the editor. Also using "reimport" does not actually reimport the static mesh anymore. Please fix these, I use them all the time.

avatar image Ben Halliday STAFF Jul 11 '14 at 09:51 PM

The developers are still looking into the marquee select issue, but there is no fix for it yet. For now, the best group-select option is to hold Shift+Ctrl+Alt and drag in the Perspective Viewport.

The reimport issue is unrelated. I believe it's a known issue, but I would encourage you to open a new post in Bug Reports and follow the information for bug posting from this post: https://answers.unrealengine.com/questions/12363/how-do-i-report-a-bug.html

I think repro steps for that issue are going to be the most important details you can give us. Thanks!

avatar image deathclonic Jul 11 '14 at 09:57 PM

Alright, sounds good. I'll do that.

avatar image deathclonic Jul 11 '14 at 10:00 PM

I'm canceling my subscription until the marquee issue is resolved.

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

Hey,

Just wanted to give everyone an update on this. It looks like the issue has been resolved internally, and will likely be included in 4.4. There is not an official date for 4.4 yet, but we've been doing a roughly monthly update so we're looking at about mid-August.

In the meantime, please be aware that marquee select can be performed in Perspective view by holding Shift+Ctrl+Alt and LMB-dragging. Thank you all for your patience while we investigated and fixed this bug!

Ben Halliday

more ▼

answered Jul 18 '14 at 07:54 PM

avatar image master_rigel Jul 19 '14 at 06:24 AM

Hi Ben. Thanks for letting me know. I'll resubscribe as soon as 4.4 ships. I hate to be a stick in the mud, but the selection issue is a real show stopper. I can use perspective selection option but it's ALLOT of keystrokes. If I could set it to be an arbitrary key combination instead, that would be awesome, or even just hold down left and right mouse button at the same time. I think the way it is now was just a bad design decision. I understand that there is probably a method to the madness but I really don't see it.

Thanks, Rigel

avatar image Ben Halliday STAFF Jul 21 '14 at 05:58 PM

I can understand that, and it's why we asked the developers to make it a priority to get it fixed for 4.4.

The Perspective marquee select option isn't intended to replace marquee select in Orthographic viewports, generally. I was hoping it might be a viable workaround for you while we worked on fixing this bug. As I'm sure you're aware, it's far more efficient to do it in Ortho, so it's possible nobody considered an alternate key configuration for using marquee select in Perspective when they set up keyboard shortcuts. I can make a feature request to open up the Perspective marquee select in Keyboard Shortcuts, though that's unlikely to make it in any sooner.

avatar image Feureau Oct 03 '16 at 07:49 PM

Hi, Ben. Is there a way to make Perspective marquee select as default instead of having to hold ctrl-alt to marquee select? This is the default behavior in Maya and it'd be great to have some sort of consistency in the maya style navigation in UE.

Thanks

avatar image Sean L ♦♦ STAFF Oct 11 '16 at 07:07 PM

Hey Feureau,

Unfortunately, this is not something we're looking to implement at this time. We appreciate your feedback though, and as always feel free to post a feature request in the feedback section of the forums.

avatar image deathclonic Jul 19 '14 at 05:19 PM

Thank you so much for this, do you think you could add it to 4.3.1 maybe? I don't have a problem waiting for 4.4 but ya know, marquee select is pretty crucial.

avatar image Ben Halliday STAFF Jul 21 '14 at 05:48 PM

I can ask, but it doesn't seem likely as most of the team is already pushing on 4.4 and hot-fixes are usually reserved for crash bugs. Most likely you're looking at a bit less than a month from now.

avatar image deathclonic Jul 22 '14 at 02:51 PM

Yeah that's alright, I'm just happy to know it's been fixed.

avatar image master_rigel Aug 01 '14 at 08:44 PM

Problem fixed in 4.4 preview. This fix should roll out in the 4.4 final

I am resubscribing.

Regards, Rigel

avatar image deathclonic Aug 04 '14 at 07:59 PM

Yeah I resubbed too for this too. So happy about it. Good job Epic :D

(comments are locked)
10|2000 characters needed characters left

Hey deathclonic,

I apologize for the delay in response. There was already a bug in our database for this behavior, but I was able to update it with what we've found and included your test asset as an example for our developers to look at. I don't know any timeline for when it will be fixed, however.

I also noticed something strange with one of your .uassets when I moved it over to a blank project. When viewed in wireframe in Top, Side, or Front views, they only displayed a single, skewed polygon. I would like to see if there is another bug hidden in here. Would you mind providing the maya file for one of the models you uploaded previously? The 512x32 was fine, so I'd like to take a look at the 128x32 if possible. Thanks!

Ben Halliday

more ▼

answered Jun 24 '14 at 09:13 PM

avatar image Ben Halliday STAFF Jun 26 '14 at 05:53 PM

Could you send us the actual maya file? It should be a .ma or .mb file type. Thanks!

avatar image deathclonic Jun 29 '14 at 12:30 AM

Oh I don't have an actual .ma file for those anymore. After I exported them I just deleted the file lol. I decided to do most of my mapping in maya for now, basing it off of the strategy game examples level design. Seems like I'll make more progress that way anyway, Which makes me wonder if there could ever be some kind of auto import or streaming plugin for maya > UE4 so I can see my progress in real time or whenever I save the .ma file.

avatar image deathclonic Jun 29 '14 at 12:48 AM

Maybe GameDraw will get support for UE4. That would be awesome.

(comments are locked)
10|2000 characters needed characters left

I can reproduce this behavior on a new project.

In 4.2.1 Create a new project with sample assets Go into orthographic view. Select the entire scene.

Anything with the title "Floor" will be left un-selected.

more ▼

answered Jun 30 '14 at 07:58 AM

avatar image

master_rigel
166 8 16 20

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question