x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Emmisive materials not working in-game and in-level bp bug

Hello,

Today I message with two issues...

On one side I have an emmisive material that loses its glow in-game, whether its in-editor, standalone or build. I have no idea to what's going on... I'll upload two images here:

alt text

This is what it should look like. On the left we see a truck with an instanced dynamic material that has a scalar parameter of Emmision to 0.0. On the right, we have the Lamp which only has a standard emmisive material.

In game, however, this is what I get:

alt text

The BP values are "nulled out" and the emmisive material loses its emmisivenes...

What is going on?

Thanks guys :)

I'm using 4.12.5

Product Version: UE 4.12
Tags:
emmisive1.jpg (74.4 kB)
emmisive2.jpg (89.1 kB)
more ▼

asked Nov 23 '16 at 05:59 AM in Bug Reports

avatar image

me4dinosaur
251 15 14 20

avatar image Ed Burgess ♦♦ STAFF Nov 25 '16 at 04:05 PM

Hi bryst,

I have a few questions that would help clear things up. When you say your lamp is using a standard emissive material do you mean that you have assigned a material directly to it and are not using a dynamic material instance?

I suspect that something is influencing the light in-game which is why you lose your emissive value when playing. Would you mind sharing your blueprint in a screenshot for the lamp. Especially if it is interacting with the material at all.

Could you also provide a screenshot of the material graph for the lamp material.

Considering emissive values are working for other assets (like the truck) leads me to think that something is going on either in your material or your blueprint rather than this being a bug with the engine.

Thanks

avatar image me4dinosaur Nov 29 '16 at 04:18 AM

Hello Ed,

It's not using a dynamic instance, nope.

I did get a message in the log saying that there was no parameter found in material property... So what do I do with this?

avatar image Ed Burgess ♦♦ STAFF Nov 29 '16 at 04:04 PM

Could you provide a screenshot of the material graph for the lamp material?

Otherwise, I can't give you specific advice since I don't know what your material setup looks like.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

You need to create a dynamic material instance either in construct or the event graph using the searchlight material as a base (or whatever material goes along with the asset). You can then access the parameters of the material and set them in Blueprint. Here is a video series tutorial that we provide for this kind of stuff: https://www.youtube.com/watch?v=srUSDU1u0og

more ▼

answered Dec 06 '16 at 10:58 PM

avatar image me4dinosaur Dec 07 '16 at 01:35 PM

I'll give that a try.

Also, this is probably not your field but could someone from Epic help me out on this one?

https://answers.unrealengine.com/questions/532497/index-1-received-swap-message-with-child-index-ser.html

avatar image Ed Burgess ♦♦ STAFF Dec 07 '16 at 01:47 PM

You have an epic staff member assigned and they should respond to your post soon.

avatar image me4dinosaur Dec 11 '16 at 08:13 AM

Thank you very much, sir!

Also, I confirm that the dynamic instance creation of the material worked nicely!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

Thanks,

Ed Burgess

more ▼

answered Dec 05 '16 at 02:32 PM

avatar image me4dinosaur Dec 05 '16 at 05:19 PM
avatar image Ed Burgess ♦♦ STAFF Dec 05 '16 at 06:12 PM

There is nothing wrong with your material that I can see for the lantern(searchlight). My guess would be that you are using a dynamic material instance and the parameters are getting changed at runtime. Could you look at the blueprint for the searchlight and make sure you aren't doing anything to the material at runtime.

The best way to narrow this down would be to get the searchlight static mesh put it into the level and then apply the material (not a material instance) of the Emmission_Yellow_1 material that you took a screenshot of.

If the emissive is glowing on the static mesh with the material applied then that should stay the same when you play in the editor. That would essentially be proof that something is going on in your blueprint.

avatar image me4dinosaur Dec 06 '16 at 03:10 AM

Ok, I'll give that a try. I'll keep you posted.

And what about the truck?

avatar image Ed Burgess ♦♦ STAFF Dec 06 '16 at 02:31 PM

It looks like the opposite is happening to the truck right? Where it has an emissive value until you play then it goes away. That can be tested in the same way as the spotlight. There is probably something in the blueprint accessing your emissive value and setting it to 0 on begin play. You can test this by using a basic material that doesn't have parameters.

Basically, we have no reports of dynamic material instances being broken and I haven't experienced it on my end with testing. I looks and sounds like you are setting those emissive parameters at runtime by accident. I can't say for sure without being able to look at your blueprint.

avatar image me4dinosaur Dec 06 '16 at 08:08 PM

that solved it for now but I want to be able to access this realtime but doesn't work when I try to access it dynamically it doesn't work at all.

Any workarounds for this? :P

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question