x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaged build crashes after 30 seconds

My packaged build consistently crashes after 40 seconds, even when there is no user input, something just seems to trigger a crash. On several builds the log would simply stop and not give me any useful message but this time it did log something useful

 [2016.11.26-07.05.39:717][957]LogWindows: Windows GetLastError: The operation completed successfully. (0)
 [2016.11.26-07.05.39:717][957]LogWindows: Windows GetLastError: The operation completed successfully. (0)
 [2016.11.26-07.05.39:718][957]LogWindows:Error: === Critical error: ===
 [2016.11.26-07.05.39:718][957]LogWindows:Error: 
 [2016.11.26-07.05.39:718][957]LogWindows:Error: Fatal error: [File:D:\Build\++UE4+Release-4.13+Compile\Sync\Engine\Source\Runtime\RenderCore\Private\RenderingThread.cpp] [Line: 721] 
 [2016.11.26-07.05.39:718][957]LogWindows:Error: Rendering thread exception:
 [2016.11.26-07.05.39:718][957]LogWindows:Error: Fatal error!
 [2016.11.26-07.05.39:718][957]LogWindows:Error: 
 [2016.11.26-07.05.39:718][957]LogWindows:Error: Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0xffffffff

It should be noted that when using my pawn's parent class (BasePlayerClass) it doesn't crash, but when switching back to its more functional child (BasePlayerClass_BP) it does crash. However even when I disable tick and unhook any events from Event-Begin-Play it still crashes after 40 seconds each time even with no player input (I have no events or functionality triggering). And my main menu level with my main menu pawn doesn't crash ever, however my playable level with my main-menu-pawn still causes a crash, so it can't be my pawn. So something odd is happening.

The full log is attached below, any help would be greatly appreciated.

link text

Product Version: UE 4.13
Tags:
more ▼

asked Nov 28 '16 at 01:37 AM in Packaging & Deployment

avatar image

HuntaKiller
160 10 12 19

avatar image HuntaKiller Nov 26 '16 at 09:08 AM

I made a copy of my pawn, deleted nearly everything and it still crashed. One of the last things the pawn had was a Post Process component (so the player has access to post process stuff). After deleting that (with a bare player extended from my BasePlayerClass) it did not crash. So I figured JUST deleting the post process component would fix it. I was wrong, still crashes. I'll be doing some more testing along these lines but I'd appreciate some direction, I have had multiple logs give me that rendering thread exception.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I never figured out the problem. Upgrading the engine version solved the crashes. I did not change any assets, simply upgraded the engine, must have been a bug somewhere on the engine side. I was using 4.13.1, I upgraded to 4.13.2 and it does not crash now.

more ▼

answered Dec 01 '16 at 03:46 PM

avatar image

HuntaKiller
160 10 12 19

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey HuntaKiller,

It sounds like the asset definitely has something going on with it. Here's what I'd recommend:

Try creating a new project and creating that asset from scratch. With each addition, try to package and play the game to see if it crashes. When the crash occurs, then you'll know exactly what addition is causing the error. If it does not crash once the asset is completely recreated, you can chalk it up to a corrupted asset, most likely.

Let me know if you have any further questions.

Have a great day

more ▼

answered Dec 01 '16 at 02:39 PM

avatar image

Sean L ♦♦ STAFF
43.8k 485 152 440

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question