x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Shadow on topology of custom vertex normal mesh

alt text There's a slight AO shadow between the bevels in my custom vertex normals mesh. This happens in UE4 but in blender it looks fine. I imported the fbx with normals and tangents, it's set to movable with no baked lighting, I tested all the cast shadow options in the lightmass settings but nothing seams to work. alt text This also happens on low poly surfaces, this surface should appear smooth like a subdivided model due to tangent normals, but the shadow kills that look.

Product Version: UE 4.12
Tags:
untitled-1.jpg (241.6 kB)
untitled-2.jpg (210.1 kB)
more ▼

asked Nov 27 '16 at 03:54 PM in Rendering

avatar image

fingler
1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

To me it looks like a side effect of screen-space ambient occlusion. Usually it is unnoticeable, but at certain conditions( namely concave shapes with relatively low polycount) it can occur.

more ▼

answered Nov 27 '16 at 09:43 PM

avatar image

Deathrey
7.9k 130 31 293

avatar image fingler Nov 27 '16 at 11:31 PM

Turns out the post processing volume is responsible, I can turn down the AO intensity to solve the issue but then it looks bad from having no AO. I'm not able to tweak it in a way where it doesn't darken such wide angles, which would be the ideal solution. I guess I just have to add more detail to the mesh itself.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The solution was in the post processing volume as suspected. The radius option under AO settings has to be tweaked along with power, intensity, quality, mip scale to completely remove shadowing on wide angle geometry. Those were the options that worked for me, it might vary from case to case.

more ▼

answered Feb 15 '17 at 08:10 PM

avatar image

fingler
1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question