x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Map sublevels not cooking in 4.13

Hi there,

We recently updated from 4.12 to 4.13. In 4.12, when packaging the project I would specify a map, let's say myMap.umap in the mapsToCook section of defaultGame.ini. UE would then automatically cook the map persistent and all its sub levels attached to it. (myMap, mysublevel_1, etc...) Since 4.13, when cooking the same map, sub levels are not cooked anymore, only myMap.

Does anyone has any clue why this is happening?

Thanks.

Product Version: UE 4.13
Tags:
more ▼

asked Nov 28 '16 at 09:20 AM in Packaging & Deployment

avatar image

Laurent.Cahour
1 1

avatar image Steve Hardister ♦♦ STAFF Dec 05 '16 at 07:29 PM

Hi Laurent.Cahour,

Did you create a copy from your original project or write over the original. If you did not write over the original, are you still able cook the persistent map and its sub levels in 4.12?

In the 4.13 version, please try the following troubleshooting steps:

  1. Right-Click "Contents" Folder in the Content Browser and select "Fix up redirectors in Folder" -This fixes errors where the cooker cannot find the referenced asset

  2. Open each map individually and run "Map Check" (Build>Map Check) "This will show Blueprint, Code, Mesh etc. errors that may be causing packaging to fail.

  3. Delete the following folders from your project folder if you're having packaging complications: Intermediate, Saved,

  4. Delete the Config folder *Be advised that deleting this folder will result in having to re-enter all values for your Editor and Project Settings.

To avoid this:

See if deleting the Intermediate and Saved folders resolves the issue first Make a copy of the Contents of the Config folder and, if deleting does not resolve the issue, replace the new contents of the Config folder with your previously saved version.

Let me know if these steps do not resolve your issue.

Thanks,

Steve H.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Laurent.Cahour,

Since we have not heard back from you in a while, we are marking this post "resolved" for tracking purposes. However, if you are still having a problem with map sub-levels not cooking in 4.13, please respond with the requested information and we will continue to investigate.

Thanks,

Steve H.

more ▼

answered Dec 09 '16 at 08:14 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question