x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

I have weird physics when I load a level from blueprint

I've been following the Udemy course about UE4 C++, but in the course (UE 4.11), the instructor isn't facing this weird problem. If I play the map directly, physics work fine, but if I start the game from a menu and load the map with "Open level" blueprint node, I experience really weird physics.

In the video I show first the physics working fine loading the level directly and then showing the weird problem I am facing loading the level from a widget menu.

https://youtu.be/Hl1W9WdvhC4

Not sure if this is a bug or something changed from 4.11 to 4.14 that can cause this strange behavior, so help!!

As extra, the blueprint I use to load the map: alt text

Product Version: UE 4.14
Tags:
more ▼

asked Nov 29 '16 at 03:55 AM in Everything Else

avatar image

ikifenix
53 4 4 7

avatar image Speckulous Nov 29 '16 at 10:09 AM

Maybe it's beacuse you didn't unload the "MenueLevel" and they overlap somehow?

avatar image ikifenix Nov 29 '16 at 05:49 PM

I don't think that is the cause, I am not streaming level, I am fully opening another. I found that if I open the level that contains the meshes, load the menu level with the console and I use the menu to load the map, it works fine, so:

  • Open Tank level directly: OK.

  • Open Menu -> Load Tank Level: Wrong.

  • Open Tank level -> (with console command) Load Menu -> Load Tank level: OK.

avatar image rhaaw Dec 01 '16 at 02:18 PM

Getting the same behavior. I have two space levels. PIE on each works fine. The moment I try to use OpenLevel in a blueprint or ServerTravel in console, all physics goes haywire.

Did you figure anything out?

EDIT: I just tried the standalone game and at least ServerTravel works there. Might be related to PIE.

avatar image HyperToxic Jan 07 '17 at 01:55 PM

I'm having the exact same problem, with the same Udemy course. I noticed the instructor is using 4.11. I'm using 4.14.

If I load the level (directly) and play it physics on the (tank) mesh work as expected.

If I load the main menu in the editor and click "start" so that it loads the level (from a blueprint) the physics on the (tank) mesh goes nuts.

From a Windows stand-alone build it works as expected.

If anyone finds a solution I would love to hear it.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

I've fixed it by setting the SimulatePhysics to false in the blueprint by default and adding this, physics are only enabled after the level is loaded.

alt text

more ▼

answered Jun 03 '17 at 04:50 AM

avatar image

SarperSoher
43 1 2 5

avatar image Banholio Sep 15 '17 at 06:32 PM

I think this is the best answer, Alessio answer uses a solution for streaming levels, so you will get references of Test_Ground on main menu, which makes everything weird.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I am probably doing the same course you are doing right now.

The problem was opening the level through Blueprint. Apparently, when you do that, physics isn't loaded correctly. Probably something correlated with the runtime, but I'm not very sure on that. Anyhow, this I what I've done to solve it:

1) From the main editor, click Window -> Levels

This should appearalt text

2) click on Levels -> add existing...

3) add the level you want to load

4) if you want to make that your main level, you can right click the level you just added and click on Make Current

When you load your level from your blueprint, the level physics should load correctly. I hope it helps, at least, maybe this can help as a start on solving the problem definitely. One thing I still didn't test is with multiple levels, so be careful about that.

Hope I helped, sorry for bad English

Kind regards,

Alessio

asdasd.png (35.5 kB)
more ▼

answered Apr 05 '17 at 04:18 PM

avatar image

Alessio Acampora
36 2 5

avatar image mrbgz May 05 '17 at 09:26 PM

Following your instructions fixed this issue for me. I'm currently going through the udemy unreal course and was getting the same bug as described with the physics going crazy when loading the battleground level from the mainmenu level.

Thanks!

avatar image CyrusVirothian Dec 31 '17 at 12:34 AM

Adding my level fixed a terrain collision problem I was having as well, thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I'm just going to add an answer here in case it helps anyone. I had a similar problem. Crazy physics when the level was loaded in as a sub-level. In my case it was because I had simple (so bounding box) collision set on another sub-level that contained a big landscape geo. So all the physics went crazy because everything was spawned inside the collision of the landscape because it was just the bounding box. Changing the landscape collision settings fixed this (either no collision, overlap all or setting complex collision) This was why it worked fine when I opened the physics sub-level by itself because the landscape sub-level was not present.

more ▼

answered Sep 07 '17 at 12:08 AM

avatar image

gelliott
278 7 8 17

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question