x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Unreal character animation tutorial - Animations not working in play mode

Hello, I've tried researching about this problem but I feel it's a small thing I'm forgetting to do that is causing it not to work. I was following the Unreal Setting Up Character Movement tutorial ( https://docs.unrealengine.com/latest/INT/Gameplay/HowTo/CharacterMovement/index.html ) and I did everything it showed and I didn't receive any errors when pressing play, but the character stays in the idle animation position and doesn't play the run, crouch, prone or any animation other than idle.

I went through and checked every blueprint and it's the same as the tutorial, but the animation just won't show when I press the play button. I have the animation selected on the Anim class so it isn't that.

The weird thing is, the player can jump, it basically has the functions of the original unreal third person character animation, but not the AnimationBlueprint I created from the tutorial even though the Anim Class is using the tutorial blueprint I made.

When I double-click the animation in the content browser it plays perfectly fine in the animation window on the character but when pressing 'Play' the character just slides around the map in idle position, here's a video of the problem and images of my animation state machine:

http://sendvid.com/syc2dqqj - Problem

alt text

alt text

alt text

alt text

So that's the Idle animation to Walk animation, both transitions. The animation blueprint's PlayerMovement state machine and the event graph for the animation blueprint.

If you need any more images or info, please let me know because I'm a beginner with Unreal; it's my first time trying to do this and I'd appreciate the help a lot.

Thank you!

Product Version: UE 4.12
Tags:
2.png (164.3 kB)
3.png (141.5 kB)
1.png (84.0 kB)
4.png (267.3 kB)
more ▼

asked Nov 30 '16 at 01:44 AM in Blueprint Scripting

avatar image

LeSmittenKitten
1 1 2 2

avatar image Holybreath Nov 30 '16 at 05:01 PM

Are you sure your Cast to MyCharacter is not failing?

avatar image LeSmittenKitten Nov 30 '16 at 06:07 PM

I tried changing Cast to MyCharacter with an isValid? node then connecting that straight to 'Calculate direction' and the idle to walking animation plays now.. except no other animations work when I press the respective buttons - probably because there's nothing to connect the booleans to (prone, crouch, jog, jumping), since I connected those 4 booleans to the 'Cast to My Character' node.

Also, even though it's playing the idle to walk animation, it doesn't show the blendspace properly as there is no left, right or backwards animations playing. Only the forward animation.

alt text

5.png (161.0 kB)
avatar image Holybreath Nov 30 '16 at 07:04 PM

What i asked, was whether MyCharacter is the real blueprint you're using for your character :) May be you haveThirdPersonCharacter set as default, so the cast will fail, and nothing will happen.

avatar image LeSmittenKitten Nov 30 '16 at 11:45 PM

Oh I see! I just tried dragging MyCharacter blueprint class into the level and it spawned another mesh so maybe it'll work now with this new character mesh? I just have to figure out how to run the game through him instead of the default ThirdPersonCharacter...

avatar image LeSmittenKitten Nov 30 '16 at 11:47 PM

Because, in the gamemode the default pawn class is set to MyCharacter but it still starts the game through the original ThirdPersonCharacter

avatar image Holybreath Dec 01 '16 at 09:59 AM
  1. Make sure you're using your proper gamemode then

  2. check if there are no level overrides for game mode. hope it helps

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question