x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

UE4 4.14 and 4.13 crash at launch

Hi I have an issue with UE4 version 4.14 and 4.13 when I try to launch the editor.

I have a Mac with OSX 10.11.6 (El Capitan) and UE4 crash report give me this error code : "SEGV_MAPERR at 0x3" any ideas ?

Thx

Product Version: UE 4.14
Tags:
more ▼

asked Nov 30 '16 at 09:36 PM in Bug Reports

avatar image

HERMAN KOLGEN
1 1 2

avatar image Steve Hardister ♦♦ STAFF Dec 01 '16 at 10:36 PM

Hi HERMAN KOLGEN,

The error code : "SEGV_MAPERR at 0x3" is a general code that can be caused by a number of various reasons. In order for us to troubleshoot the issue, please copy the entire contents from the Crash Reporter window, paste them into a text doc and attach to your reply. Be sure to hit submit on the Crash Reporter pop-up and that your Machine ID is included in the Crash Report.

One thing you can try immediately that may resolve the issue is to delete the DerivedDataCache folder from the install directory, then try to launch the Editor. Another thing would be to reinstall this version of the editor and then verify the install: Launcher>Library>EngineVersion [click on yellow down arrow on icon] >Verify.

Try the troubleshooting steps first, then provide the requested information if this does not succeed.

Thanks,

Steve H.

avatar image MohHeader Dec 02 '16 at 06:38 AM

Just wanted to add,

That I have the same issue But in my case,, the whole machine is hangs ( can't use neither mouth nor keyboard ) And the only solution is to restart the machine,,

So I have no error to submit :( ...

Thanks,

avatar image HERMAN KOLGEN Dec 05 '16 at 07:05 PM

MachineId:F766193CC44A07AC1787B5A328E7C0DD EpicAccountId:3bdf7d53f3d2494a8ea3c944b227e18d

SEGV_MAPERR at 0x3

FGenericPlatformMisc::RaiseException(unsigned int) Address = 0x10026edbb (filename not found) [in UE4Editor-Core.dylib] FOutputDeviceMacError::Serialize(wchar_t const*, ELogVerbosity::Type, FName const&) Address = 0x100427378 (filename not found) [in UE4Editor-Core.dylib] FOutputDevice::Logf(wchar_t const*, ...) Address = 0x100504d17 (filename not found) [in UE4Editor-Core.dylib] FDebug::AssertFailed(char const*, char const*, int, wchar_t const*, ...) Address = 0x100483b7e (filename not found) [in UE4Editor-Core.dylib] FMetalDeviceContext::CreateDeviceContext() Address = 0x1385a23b9 (filename not found) [in UE4Editor-MetalRHI.dylib] FMetalDynamicRHI::FMetalDynamicRHI(ERHIFeatureLevel::Type) Address = 0x1385c723b (filename not found) [in UE4Editor-MetalRHI.dylib] FMetalDynamicRHIModule::CreateRHI(ERHIFeatureLevel::Type) Address = 0x1385c70f4 (filename not found) [in UE4Editor-MetalRHI.dylib] PlatformCreateDynamicRHI() Address = 0x10645b06b (filename not found) [in UE4Editor-RHI.dylib] RHIInit(bool) Address = 0x10645c535 (filename not found) [in UE4Editor-RHI.dylib] FEngineLoop::PreInit(wchar_t const*) Address = 0x10017cb3f (filename not found) [in UE4Editor] GuardedMain(wchar_t const*) Address = 0x10018f8a1 (filename not found) [in UE4Editor] -[UE4AppDelegate runGameThread:] Address = 0x10019d16c (filename not found) [in UE4Editor] -[FCocoaGameThread main] Address = 0x1003b6526 (filename not found) [in UE4Editor-Core.dylib] Unknown() Address = 0x7fff915efe64 (filename not found) [in Foundation] _pthread_body Address = 0x7fff97ac099d (filename not found) [in libsystem_pthread.dylib] _pthread_body Address = 0x7fff97ac091a (filename not found) [in libsystem_pthread.dylib] thread_start Address = 0x7fff97abe351 (filename not found) [in libsystem_pthread.dylib]

avatar image Steve Hardister ♦♦ STAFF Dec 07 '16 at 08:57 PM

I could not find a match for this on our Crash Reporter data site. Are you hitting submit when the Crash Reporter window pops up? If you haven't already, please do this at least one time.

avatar image Steve Hardister ♦♦ STAFF Dec 02 '16 at 10:39 PM

Also, be advised that UE4.14 no longer supports Open GL 4 so that may be an issue... However, UE4.13 should still be functional. Please post your Mac's Specs to see if there is a hardware conflict. -Thanks

avatar image HERMAN KOLGEN Dec 12 '16 at 04:19 PM

I updated to system 10.11.6 and still have the problem.

I presume is my graphic card an old ATI Radeon HD 5770 1024 MB openGL 4

herman

avatar image Steve Hardister ♦♦ STAFF Dec 13 '16 at 03:23 PM

List of Mac computers that support Metal

From the above list, it would appear that your system does not support Metal, and thus you would not be able to run UE4.14. However, you should still be able to run up to UE4.13.2.

Try uninstalling, the reinstalling UE4.13.2. Try to launch and if you get another crash, please be sure to hit the "submit" button in the Crash Reporter window. I'll use the information you have already supplied to try and track this data and see if your crash can be linked to one that has already been resolved.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi HERMAN KOLGEN,

Since we have not heard back from you in a while, we are marking this post "resolved" for tracking purposes. However, if you are you still experiencing crashes when trying to launch UE4.13 or UE4.14, please respond with the requested information and we will continue to investigate.

Thanks,

Steve H.

more ▼

answered Dec 12 '16 at 03:09 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question