x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Valid Development Provision and Certificate ignored for tvOS [Workaround]

Update: Here is a screencast of the entire process.

Steps to Duplicate:

  1. Create First Person Blueprint project, "Desktop/Console", "Max Quality", "No Starter Content"

  2. Set bundle information.

  3. Import a development certificate and provision.

  4. Attempt to package for tvOS or to Launch on AppleTV

Here is the Output Log Snippet

This is what it looks like.

Config Screenshot Message Log Screenshot Output Log Screenshot

Product Version: UE 4.14
Tags:
more ▼

asked Dec 02 '16 at 04:41 AM in Bug Reports

avatar image

CleanCut
2.1k 67 84 77

avatar image Samantha Sutton ♦♦ STAFF Dec 08 '16 at 05:19 PM

CleanCut,

As we discussed on your previous AnswerHub, you're going to reinstall your Mac OS and see if that fixes the issue. However, here are the steps where I was able to resolve my issue with the developmental version of tvOS:

  • Closed the Editor

  • Removing my provisions from the provisioning profile

  • Opened the Editor back up

  • Added only the Provisions that I needed for tvOS

  • Added only the certificate that would be used for tvOS

  • Packaged the project for tvOS

This corrected the issue for me. I know you have double checked multiple times that you've used the correct provisions and certificates, but you might need a complete refresh.

There was some provisioning logic changed when Xcode was updated therefore, any older certificates/provisions were causing errors during packaging.

Upload new logs as you continue testing, please.

avatar image CleanCut Dec 09 '16 at 12:04 AM

I didn't anticipate 4.14.1 coming out while I was doing my fresh install...interesting. Unfortunately, not any better.

  • From-scratch installation of macOS Sierra 10.12.1 and UE 4.14.1 - no restoring from backups.

  • Description alt text

  • Packaging alt text

  • Imported development certificate and provision (this used to go green in 4.14.0, even though it didn't work) alt text

  • Error alt text

link text

avatar image CleanCut Dec 09 '16 at 03:11 AM

I want to be sure that I'm following the correct certificate/provision process, so I'm redoing everything else now:

  • I deleted my certificates from Apple's developer site and generated new ones.

  • I deleted my old certificate from Keychain Access and my old provision from ~/Library (the ones added in the last attempt before I nuked the certs on Apple's site)

  • The newly generated certificate and provision imported green, but still didn't work (see attached log) alt text alt text

  • Here is how I generated the new certificate and provision: alt text

avatar image CleanCut Dec 09 '16 at 03:27 AM

I did all the same things as in the last post, only using a wildcard app id and a provision that uses it. Same errors in the logs.

I really don't see how I could possibly have gone more "from scratch" than this. I have worked on this every day since November 26th. I have tried 5 versions of UE (including source builds), two versions of macOS each on two different macs, reinstalled macOS Sierra from scratch and all programs from scratch, deleted all my certificates, app ids, and provisions and recreated them. I don't know what else I could possibly do! From my perspective, the tvOS feature has been completely broken for both development (this post) and for distribution. Lousy timing for me to try to release my first commercial app. :-(

Perhaps you and/or the tvOS developer could try a "completely from scratch" setup? Something! Anything!

Also, I am willing to send you the certificate and provisions via some more private means and you can test with them yourselves. Just let me know if you want to try that and I will arrange for you to download them.

alt text alt text alt text alt text

avatar image Samantha Sutton ♦♦ STAFF Dec 09 '16 at 06:09 PM

I was able to package (in development) for tvOS in 4.14.1 on macOS Sierra without any trouble. Could you please submit your provisions and certificates to me through a private message on the forums?

Thank you. :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

In the other thread about the distribution side of things, I found a workaround that gets past the development issues. The workaround doesn't get past all the distribution issues, though. :-(

more ▼

answered Dec 30 '16 at 10:54 PM

avatar image

CleanCut
2.1k 67 84 77

avatar image tsnyd Jan 19 '17 at 05:26 PM

Any updates with this? I am having the same issue with packaging for iOS where none of the proposed solutions work.

avatar image CleanCut Jan 20 '17 at 06:56 PM

Not that I'm aware of.

avatar image tsnyd Jan 20 '17 at 09:43 PM

Were you able to get it onto iTunes connect in any way? Or are we just waiting for them to fix the issue.

avatar image CleanCut Jan 20 '17 at 10:22 PM

No. I have not been able to get a tvOS package submitted to iTunes connect under any conditions with any version of the engine.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

CleanCut,

Please check the information I posted on your other AnswerHub. Please let me know what I can do to further assist you with the problem you're running across. Hopefully the tips provided help figure out what's going on.

Thanks!

more ▼

answered Dec 15 '16 at 04:30 PM

avatar image CleanCut Dec 15 '16 at 06:44 PM

As I mentioned in the other post, I have no idea what to change in the certificates/provisions in order to make things work. The certs work just fine with iOS provisions. I can't see anything to do differently with the tvOS provisions. Feels like a cop-out to me.

avatar image CleanCut Dec 15 '16 at 07:27 PM

That is really not a helpful answer. I tried making my certificate and provision names simpler. I can't see anything else I could possibly change.

alt text

avatar image Samantha Sutton ♦♦ STAFF Dec 21 '16 at 10:22 PM

Your set up looks fine from the screenshots provided. However, it looks as though you're using a .cer file as the certificate. If you're attempting to use this on a Mac other than the .CSR, you'll need to generate a .p12 in Xcode. .cer files will only work on the computer that the .CSR was generated on.

If you'd like, we can further debug the issue if you could provide us with the .p12.

I'll post this on your other question too, just in case - thanks!

avatar image CleanCut Dec 23 '16 at 05:20 AM

I left a comment in the other post detailing how I am unable to generate a .p12 file.

avatar image CleanCut Dec 27 '16 at 07:52 PM
avatar image Samantha Sutton ♦♦ STAFF Dec 29 '16 at 10:41 PM

I watched your YouTube video and I did not notice any mistakes in your certificate and provision creation process.

Follow the .p12 setup process found on the website Calvium. The guide is very direct and detailed. I was unable to find much information within our released documentation for the .p12 creation process.

Sorry for the delay, holiday hours make our response time longer than usual. I hope you have a great New Year! (Minus this current headache).

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question