x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

anyone know why 4.2 behaviour tree crashes

in the Behaviour trees some of my Blueprints will not execute in version 4.2 and they are labled with a prefix REINST_ i have tried replaceing all the Blueprints and this works fine until i reload the project and the Behaviour trees revert back to the same state. if i double click the node to edit the Blueprint i get a Crash

SIGSEGV: invalid attempt to access memory at address 0x3

EngineCrashHandler(FGenericCrashContext const&) Address = 0xe00978f (filename not found) [in UE4Editor] PlatformCrashHandler(int, __siginfo*, void*) Address = 0xe2ae0bf (filename not found) [in UE4Editor-Core.dylib] _sigtramp() Address = 0x9087e5aa (filename not found) [in libsystem_platform.dylib]

Help Please

Product Version: Not Selected
Tags:
more ▼

asked Jun 06 '14 at 07:58 PM in Bug Reports

avatar image

Alan Webster
820 47 28 75

avatar image DJMidKnight Jun 06 '14 at 09:32 PM

from what I have read you are not the only one having this issue. I pretty much have to just leave the editor open so I don't have to keep fixing the BT but luckily mines only about 10 nodes I can imagine how painful this would be with something more complicated.

Hope they can fix this in a hotfix or at least get it somewhat back to the 4.1 version

avatar image Alan Webster Jun 06 '14 at 10:00 PM

Thanks for letting me know it's not just me, not having much fun with the engine at the moment just seem to be fighting bugs all the time.

avatar image TJ V ♦♦ STAFF Jun 07 '14 at 02:36 PM

Hi Alan,

Could we get your dxdiag, crash logs, and some screenshots of your behavior tree setup? I am going to loop in another developer to help out with your issue.

avatar image Alan Webster Jun 07 '14 at 04:05 PM

this is from a test project all created in 4.2 Mac OSX if i click the blue text in the details panel it opens the BP ok if i double click the the node i get a crash SIGSEGV: invalid attempt to access memory at address 0x3

EngineCrashHandler(FGenericCrashContext const&) Address = 0x594b78f (filename not found) [in UE4Editor]alt text PlatformCrashHandler(int, __siginfo*, void*) Address = 0x5bec0bf (filename not found) [in UE4Editor-Core.dylib] _sigtramp() Address = 0x8da3f5aa (filename not found) [in libsystem_platform.dylib]

Thanks for your Help

bthelpme.jpg (361.6 kB)
avatar image Alan Webster Jun 07 '14 at 04:06 PM

This is the task BPalt text

bttask.jpg (327.3 kB)
avatar image Alan Webster Jun 07 '14 at 06:25 PM

don't know how to get DXDIAG on OSX

Model Name: iMac

Model Identifier: iMac12,2

Processor Name: Intel Core i7

Processor Speed: 3.4 GHz

Number of Processors: 1

Total Number of Cores: 4

L2 Cache (per Core): 256 KB

L3 Cache: 8 MB

Memory: 12 GB

Boot ROM Version: IM121.0047.B1F

SMC Version (system): 1.72f2

avatar image TJ V ♦♦ STAFF Jun 07 '14 at 06:40 PM

I'm sorry, I didn't realize you were on a Mac, don't worry about a dxdiag, that is for PC only. The info you gave is exactly what we need. Could you also include you Crash Logs?

On a Mac, the Crash logs are located in: /Users/UserName/Library/Logs/DiagnosticReports/ The Library Folder is hidden by default. The easiest way to get to it is by having finder the active application and while holding Option Click Go in the Mac Menu Bar. This will expose Library.

avatar image Alan Webster Jun 07 '14 at 07:10 PM

i got plenty of them

avatar image IceWraith STAFF Jun 09 '14 at 03:48 PM

Those are logs from crash reporter tool, can you also include files that were being uploaded? Log says they are located in:

/Users/Alan/Library/Application Support/Epic/UnrealEngine/4.2/Saved/Crashes/CrashReport-MyProject8-pid-1227/

Diagnostics.txt should contain callstack, which will help to determine what happend.

avatar image Alan Webster Jun 11 '14 at 03:44 PM

Hi Lukasz, is there any news or progress on this isue? its looks like many more people have the same problem. Thanks

avatar image IceWraith STAFF Jun 11 '14 at 03:56 PM

I can't get a local repro for root case of problem - nodes switching to REINST_ classes. Currently task sits on QA.

avatar image Alan Webster Jun 11 '14 at 04:08 PM

sorry, what does QA mean? is there likely to be a fix in the near future? should i stop working on Ai for now and concentrate on other parts of my project? and any idea when the behaviour tree will come out of the experimental stage?

avatar image IceWraith STAFF Jun 11 '14 at 04:24 PM

I'm sorry, should've been more specific: QA stands for quality assurance.

Hopefully this bug is already fixed on our side in most recent version and that's why it was not occurring for me, even though steps you've described says that it happens all the time.

Hotfix for build 4.2 is currently being prepared and should be distributed via launcher as an automatic download early next week. For the time being, please focus on different part of your project :)

As for behavior trees and their experimental stage, we're aiming to finish editor usability pass for 4.3 release.

avatar image Alan Webster Jun 11 '14 at 05:06 PM

Ok Thanks, Not feeling to confident but we shall see. thanks again for you're help and the info, ill post here again after the update.

avatar image intoxicat3 Jun 11 '14 at 05:53 PM

Lukasz this maybe a tip for reproduction - I've converted project from 4.1.1 (haven't had any animation trees and haven't enabled it in experimental options). After upgrading created Tree and now I need to create my tasks again in Behavior Tree when I load the editor again.

avatar image dbc211 Jun 09 '14 at 04:57 PM

I've been having this problem since long before 4.2. Here's my answers thread on it: https://answers.unrealengine.com/questions/36886/custom-behavior-tree-services-tasks-not-working-af.html

It seems to have to do with accessing external variables or objects from inside a behavior tree type blueprint, specifically variables declared inside your AIController. Possibly some sort of circular reference during compile time (AIController calls behavior tree which calls a service/task/decorator blueprint which calls a variable in AIController)

avatar image Alan Webster Jun 10 '14 at 01:45 PM

Hi abc211 I have multiple character types all interacting with each other in different ways, it's taken weeks for me to build and I don't fancy attempting the workaround you have. Luckily for me it works in 4.1 and am still working on the AI in 4.1 frustrating because I have other issues in 4.1 that have been resolved in 4.2. Hopefully our friends here can come up with a fix for us all.

avatar image Alan Webster Jun 09 '14 at 05:24 PM

Thanks Pal

[1]: /storage/temp/8105-diagnostics.txt

diagnostics.txt (37.2 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Try making a new behavior tree in 4.2, recreating what you had. It worked for me. There seems to be a problem upgrading trees from 4.1

Epic specifically warned this might happen in one of their twitch streams, since the behavior trees are still experimental and all. It's probably a bad idea to make a really elaborate tree you don't want to remake at this point in time.

more ▼

answered Jun 07 '14 at 01:01 AM

avatar image

3DMoss
117 9 16 227

avatar image Alan Webster Jun 07 '14 at 09:31 AM

thanks for that but that was one of the first things i Tried and didn't work just tried again as you suggested. it works fine until i close the engine and reload the project then it don't work again.

avatar image Alan Webster Jun 07 '14 at 02:09 PM

just started a new project in 4.2 created everything new a character, data asset, behaviour tree and Tasks. all great, a little man runs around all happy as expected but the same fault happens when i close down and reload the project

avatar image intoxicat3 Jun 11 '14 at 01:22 PM

I've the same issue!

Created everything in clear 4.2 and when I close Editor and open it again all of my Task have REINST_ before the name and I need to add them again to BehaviorTree to execute them.

Anyone know how to resolve this? It's pain to copy and paste tasks in Behavior Tree every time I open the editor.

avatar image Alan Webster Jun 11 '14 at 03:51 PM

Don't know yet pal, the problem is way beyond my capabilities to resolve. hoping the Epic guys can com up with something soon.

avatar image seenooh Jul 24 '14 at 12:48 AM

I'd like to follow up on this matter, as I'm facing the issue ever since 4.2. We were forced to use the source and build from there which solved the problem, and we could accept that as temporary solution. However, we want to stay away from source as we don't need it, and it's alot simpler using the launcher to work with folks remotely.

We upgraded to 4.3, and unfortunately the problem is back. It seems to me that for some reason, this never happens if you use the source code.

We'd appreciate if someone can help us with this.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Finally some good news! I built the editor from the source (it was tagged as version 4.2.1) and indeed, no more problems. So hopefully it'll be fixed for everyone after the hotfix next week!

more ▼

answered Jun 12 '14 at 07:20 PM

avatar image

dbc211
116 6 7 13

avatar image Alan Webster Jun 12 '14 at 07:49 PM

made me smile

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question