x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can I control falloff of Specular highlights on Mobile ES2?

Hi,

I have noticed that the default specular level in mobile seems to be maxed out. The specular material input has no effect on mobile so I cannot scale it back in anyway. I'm trying to match the default value on PC but there doesn't seem to be anyway to do that.

Any help?

This is the PC with its default spec of 0.5 alt text

And this is Mobile ES2 with its default spec setting. .. A bit blown out.

alt text

Product Version: UE 4.12
Tags:
pcspec.jpg (37.8 kB)
es2spec.jpg (37.3 kB)
more ▼

asked Dec 06 '16 at 02:20 PM in Rendering

avatar image

TeamKingdom
87 9 10 15

avatar image TeamKingdom Dec 07 '16 at 02:12 PM

I tried this again with version 4.14 and now I do have some control over the spec on Mobile ES2. But not much. These images show mobile with settings of SPEC at 1 and SPEC at 0. alt text alt text

spec_1.jpg (115.0 kB)
spec_0.jpg (106.3 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I know virtually nothing about mobile rendering, but the falloff issue is one of roughness rather than specularity. At least on desktop rendering.

Try setting the Roughness to 1.

more ▼

answered Dec 07 '16 at 07:45 PM

avatar image

Wilkes
96 6 9 15

avatar image TeamKingdom Dec 07 '16 at 08:19 PM

Thanks for taking the time to comment. I shouldn't have used the term "falloff", its misleading. Yes the roughness does handle the spread or falloff of the reflection but the spec setting controls the intensity of that result. The roughness setting seems to give the same results on both but if you set the spec to zero on pc shader model 5 then you have 0 reflection intensity. (Spec input in ue4 would probably be better named as reflection intensity)

Mobile settings seem to always have a high intensity, even at a zero setting.

avatar image Wilkes Dec 07 '16 at 08:21 PM

I see. Wish I knew more about mobile rendering to help you as this seems like a pretty bad problem.

avatar image TeamKingdom Dec 08 '16 at 04:45 AM

Guess I will Log it as a bug.

avatar image Institute Games Aug 23 '17 at 05:01 PM

TeamKingdom, did anything come of this, as I am experiencing this issue as well.

avatar image TeamKingdom Aug 24 '17 at 03:11 AM

Hi Card and Dungeon, The problem seems to have been fixed in my testing. I see you have also responded in this answer hub thread

https://answers.unrealengine.com/questions/534366/bug-mobile-specular-settings-are-twice-as-strong-a.html

The test I did in that thread (Create a material with 0 color, 0 spec and 0 roughness) seems to work OK. Spec response on ES2 or mobile matches the shader model 5 intensity. (The shape of the specular dot is different but the intensity does match.)

If you have a specific example you would like to share I would be happy to see if I can recreate your problem.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question