x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Media Texture is not working on UNREAL ENGINE 4.13

Good evening. I am a beginner in UR4 and would like to put a video with a skip button before the menu of my game. I try to follow some tutorials, but the media texture turns black and does not appear in my blueprint widget. But if I open my MediaPlayer and run my video without closing this file the texture plays the video. But if you close the playback the texture will turn black again. Can someone help me?

The error https://youtu.be/py1x3N4ppFY

alt text import assets cinematics_video and cinematics_audio

alt text right button -> media -> media player

alt text open file MediaPlayer and run cinematics_video

alt text create texture and widget to texture_video

alt text Media texture turns black and does not appear on my blueprint widget. But if I open my MediaPlayer and run my video without closing this file the texture plays the video. But if you close the playback the texture will turn black again.

Product Version: UE 4.13
Tags:
mediatexture1.png (306.2 kB)
mediatexture2.png (406.6 kB)
mediatexture3.png (119.8 kB)
mediatexture4.png (383.9 kB)
mediatexture5.png (138.6 kB)
more ▼

asked Dec 07 '16 at 02:42 AM in Rendering

avatar image

Tognere
6 2 3 4

avatar image Tim Hobson ♦♦ STAFF Dec 07 '16 at 09:50 PM

Hi Tognere,

You need to also create a Media Playlist and put assign the created Media source in there so that it plays. You can then use the Widget's Graph to play/pause/etc like you would previously.

-Tim

avatar image gmpreussner STAFF Dec 08 '16 at 12:05 AM

Playlist is not required. What's missing is the Blueprint that opens the media source at runtime.

avatar image gmpreussner STAFF Dec 08 '16 at 12:04 AM

What's missing here is that you need to actually open a media source in your Blueprint script. MediaPlayers no longer store a media source to play, and they no longer auto-play. The How-To has a basic example on how to do this from BeginPlay. You probably want to add the OpenSource node in your widget Blueprint instead.

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first

Thank you friends for helping me. I was able to reproduce through the blueprint. I do not know if it was the best way but it worked ... thank you very much.alt text

soluction.png (236.4 kB)
more ▼

answered Dec 08 '16 at 01:16 AM

avatar image

Tognere
6 2 3 4

avatar image gmpreussner STAFF Dec 08 '16 at 01:59 AM

This is the correct solution :)

(comments are locked)
10|2000 characters needed characters left
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question