x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

are there any limitations for media framework on mobile devices?

Hi everyone

I am currently working on a 360° videoplayer for mobile devices. I am using four videos but somehow my galaxy s3 shows only two of them when I switch between these four. They have all the same fileformat and should be identical. I have deleted one of the working media files and then one of the not showing videos showed up. So it seems to me that there is a limitaion on how many videos can be loaded on mobile devices. Is there any rule behind it? So if I want all four videos to be in the "game" which model do I have to use?

An other question I have stumbled over is: My seek nodes appear to be not executed while playing on the galaxy s3. Is it because my phone has less power or are those nodes not available for mobile development?

Hope you guys and girls out there can help me

Greetings

Evil_Fischi

Product Version: UE 4.13
Tags:
more ▼

asked Dec 07 '16 at 04:07 PM in Using UE4

avatar image

Evil_Fischi
282 7 14 18

avatar image Evil_Fischi Dec 07 '16 at 04:10 PM

In addition: all those videos are in the content/ movies folder.....

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hi Andrew

I found the problem. I was working on 4.13.1 and Chris Babcock told me that there was a Bug with the seek note on Android devices.

Here is the link to the forum thread https://forums.unrealengine.com/showthread.php?131289-Are-there-restrictions-for-Mediaframework-for-Android

I am downloading the 4.14 and test if everything works and I will come back to tell you if this solved the problem.

Thank you very much guys ;)

more ▼

answered Dec 14 '16 at 09:05 AM

avatar image

Evil_Fischi
282 7 14 18

(comments are locked)
10|2000 characters needed characters left

Hello Evil_Fischi,

Firstly I would make sure all your videos are referencing the correct file path location from your Unreal Projects/YourProject/Content/Movies folder. They might all be in there, but be sure within the project that the file directory is referencing that location.

In regards to what is and is not expected to work, the Media Frame work as mentioned in our documentation is both Engine and Slate agnostic, which means it can be used in pretty much any application not just the game engine or the Editor. This also means that any restrictions in place for mobile for various set ups will apply to the media player as well.

Media Framework

If you would like you can provide me with a test project or steps to follow so I can try and reproduce the issue you are experiencing, on my end. Let me know if you have further questions or need additional assistance.

Cheers,

Andrew Hurley

more ▼

answered Dec 07 '16 at 06:14 PM

avatar image Evil_Fischi Dec 08 '16 at 10:00 AM

Thanks for the quick reply Andrew,

What I have done:

  • One Actor Blueprint with a big sphere where i play the video on and some planes that I shoot with a linetrace to switch between the "scenes". I have set up the file media source, media player and the material in this BP as variables

  • I have duplicated the BP three times in the scene and changed the file media source, media player and the material (everything is assigned correctly-- In the play in editor everything works as it should)

  • In my character BP I do a linetrace by channel and cast it to my actor BP and check which plane I have hit and teleport the player to the according location

Does the seek note need a higher delay infront of it to work properly?

What I have also noticed is that I have sound in my app although I have no sound assigned at all in the level. I have set up the media players to have no sound output and none of my other audio components has any sound assigned as well.

Cheers,

Evil_Fischi alt text

mediatest01.jpg (837.5 kB)
avatar image Evil_Fischi Dec 09 '16 at 02:57 PM

Today I have set up a complete new Project and just copied the stuff I was using in the old project (had tons of different movie files and other unused stuff in the project) I thought maybe I have the problem because my smartphone was running out of discspace. So that there was no room for the other videos to be deployed. When I launch the new project I only see one video, the others don't show up at all. Somehow they aren't loaded into the mediaplayers.

I have packaged the game for windows and there everything works as it should but not on my phone :/

Is there anything wrong I do codewise or is there something in my packaging setup that is not right?

One problem I have had was that I set up the project on the server and everytime I wanted to launch it to my phone it failed. I hae migrated it to my local drive and now I can launch it :)

avatar image AndrewHurley Dec 09 '16 at 06:26 PM

You have quite the unique set up here, and it would be hard for me to duplicate and have all the matching settings, even with your blueprint screenshots. You mention you got it to run correctly from your local drive, and that you had trouble when integrating the networking.

It's hard to tell what could be going wrong from your description, but as long as your movie files are being referenced locally and you be sure to package that directory, your videos should play as expected. Now there might be restrictions in place on your phone in regards to video format compatibility etc., so make sure you know the format that does work and stick to that for all your videos. You might need to do some conversion with a third party software, but that's okay.

Let me know if you have additional questions.

Thank you,

Andrew Hurley

avatar image Evil_Fischi Dec 13 '16 at 10:13 AM

Hi Andrew,

I have set up my videoplayer in a different way and now all four videos are displayed correctly. I don't know what the problem was... . The only problem I have now is that somehow the seek note doesn't work. To test that I did everything right I have created a new BP with a Mediaplayer and a plane. When I hit the BP with a linetrace I call a function in which I have a seek note with the time set to 10 seconds. When I hit the BP the Mediaplayer is set back to zero somehow. Bytheway when I test it in the editor the seek works fine, but not on mobile...

So my question: Is it a bug that my mobile device can't execute the seek?

Cheers, Evil_Fischi

avatar image AndrewHurley Dec 13 '16 at 07:10 PM

So I ran some tests on my end using the Samsung Galaxy S5 and was able to Play, Rewind, and Seek a test video. I will say upon my initial testing I had to make sure I was using the correct file path for my Media Source (MyProject/Content/Movies) folder. In other words, be sure you have copied the movie file into your movies folder and use that file path for the reference in your Media Source.

The next thing you want to make sure you pay attention to is the correct target texture compression format. In my case, the Galaxy S5 uses ASTC texture compression. This allows for everything to be packaged correctly onto my device. Therefore, I will say the only limitations I have been able to discover is that if you package for the ETC1 texture format which is supported by all Android Devices, you might not be able to use the media source as it is being compressed incorrectly.

Let me know if you have further questions or need additional assistance.

Thank you,

Andrew Hurley

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question