x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Distance Field Ambient Occlusion not visible in VR Preview window

Hi All,

Trying to troubleshoot a problem that seems specific to my workstation. I have a simple scene with Distance Field Ambient Occlusion enabled (tinted red so that it is easily visible). In the editor viewport and and when playing through "Selected viewport" or "Standalone" it is visible:

alt text

However, when I switch to the VR Preview, the Distance Field Ambient Occlusion is not rendered:

alt text

I'm using the normal deferred renderer with temporalAA, and the exact project renders correctly on a friend's workstation so I can only assume that whatever setting is different sits outside of the config files that are bundled with the project. I'm at a loss for what it could be though.

Any pointers that would assist in me troubleshooting this will be greatly appreciated. Thanks!

Product Version: UE 4.14
Tags:
viewport.jpg (131.8 kB)
vrpreview.jpg (85.0 kB)
more ▼

asked Dec 07 '16 at 11:50 PM in Rendering

avatar image

philboltt
44 5 7 12

avatar image Emil.Klingberg Mar 15 '17 at 11:55 AM

Hey did you figure it out, i can get some Ao to work in VR, but its definitively not the Distance field AO

avatar image ZEROONESTUDIO Mar 20 '17 at 08:22 AM

Hey I'm having the same issue as well. I'll try it on another machine tonight and see if it is machine-specific.

avatar image ZEROONESTUDIO Mar 20 '17 at 09:04 AM

Can confirm it is not working on a different machine

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Looks like it won't be fixed any time soon - Unrealengine123 has put the case for DFAO in VR being a bug and Epic has entered it:

https://answers.unrealengine.com/questions/578208/dfao-not-visible-with-vr.html

See bug here:

https://issues.unrealengine.com/issue/UE-43318

more ▼

answered Mar 31 '17 at 10:47 PM

avatar image

ZEROONESTUDIO
25 1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi,

Do you find DefaultScalability.ini in you project's config/ directory? Under [PostProcessQuality@#] sections, try set r.AmbientOcclusionLevels=0 to 1. I didn't test it myself, but according to this answer: https://answers.unrealengine.com/questions/523222/postprocess-features-not-working-in-the-vr-templat.html this might help.

Cheers.

more ▼

answered Jan 12 '17 at 05:28 AM

avatar image

kcmonkey
86 2 6 11

avatar image Fisher007 Mar 20 '17 at 05:04 PM

That is only an issue if you are using the VR template. Doesn't work in this case, as it seems to be global. I have checked both with 4.14 and 4.15.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question