x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why can't I see other players in multiplayer?

I tried to set up multiplayer myself, and got the two windows open ( Client and server ) and could trigger and witness doors opening in both sessions, BUT, neither session could actually see the other pawn. So I gathered the pawns where hidden for some reason , so I figured I better just look up a tutorial.

I found one of Epic's official tutorials on blueprint networking, and in this tutorial the exact same steps I took are taken, but on their end, in the tutorial they can see the other plays - I still cannot.

I have been stuck on this for a while now, as it really just seems to be something minor that I can't solve, it is clear that both players are in the session because interaction done in one session are seen by the player in the other session.

If anyone could give some insight into this, I would be very grateful.

Product Version: Not Selected
Tags:
more ▼

asked Jun 07 '14 at 11:10 AM in Using UE4

avatar image

catfishermen
6 2 3 5

avatar image devdavi Jun 07 '14 at 03:30 PM

This is a silly response, but have you made sure that player models/components are set to be visible to other players? For instance, in setting up first person shooter you make the arms visible to the player and the body not visible and the opposite for other players?

avatar image ShirtyKezRat Jun 07 '14 at 03:33 PM

If you're replicating correctly you're characters should show. Check if actual mesh/skeletal mesh is set as only seen by owner... If you are using the FPS Template the're a good chance yes.

avatar image catfishermen Jun 09 '14 at 06:05 AM

Hi, I did think this might be the issue, but I can't quite find any rendering or visibility options on the skeletal mesh, could you clue me in to where they should be? I have only recently moved from ue3 to 4 so the layout change has slowed me down considerably.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey catfisherman,

You can see the options Owner No See and Only Owner see in the Character Blueprint. Go to Defaults and scroll down to the bottom of the Rendering section. Click the little arrow to expand the section, then scroll down until you see the options for each of the two meshes. By default, the full character mesh will have Owner No See enabled, and the arms/weapon mesh will have Only Owner See enabled. You want to make sure you don't have Only Owner see enabled on the full character mesh. You can see an example of this in action in ShooterGame in the PlayerPawn Blueprint.

Hope that helps!

Ben Halliday

more ▼

answered Jun 09 '14 at 06:55 PM

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question