x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Linetrace hits something invisible only when looking at an angle, how do I fix this?

I have a linetrace setup for a projectile. When I look at an angle to a hole in my floor, it hits an invisible wall at the edge of the hole. I don't know why though, my bsp additive and subtractive brushes aren't placed like that. I have no idea what it could be hitting, can someone please help me solve this issue? I've tried so many different things and googled this problem thoroughly. I don't know what else to try.

I have images of my blueprints and some debug images of the linetrace as well.

Debug01Debug02Blueprint

Does anyone have any ideas, suggestions, or more context they would like me to provide?

Thank you, Sno

Product Version: UE 4.13
Tags:
debug01.png (1.1 MB)
degub02.png (1.2 MB)
blueprint.png (371.8 kB)
more ▼

asked Dec 08 '16 at 07:46 PM in Blueprint Scripting

avatar image

Sno-dog
6 1

avatar image chackaloso Nov 04 '17 at 11:42 AM

Did you manage to figure it out? I have a similar issue with mine...

avatar image PlainBane Nov 04 '17 at 03:33 PM

Hi, Have you tried replacing brushes with static meshes? It could be that there is some collider that's blocking visibility trace channel. Try changing trace channel in trace node to camera. Or it's the brush you are using to cut that hole in the ground. It's probably sticking out and blocking line trace.

avatar image lumakker Nov 08 '17 at 01:11 PM

Hey, I have the same problem. Any solutions in sight?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I guess there's a collider blocking your trace. Try to print the name of the object that is hit, so you can identify it and check its collider.

more ▼

answered Nov 08 '17 at 01:29 PM

avatar image

ndelchen
295 9 13 19

avatar image lumakker Nov 08 '17 at 06:49 PM

Yes, I did that. In my project the hit component (visibility line trace) is the additive brush of the wall. The subtractive brush seems to have visually created a hole in the wall, but did not fully update the collision of the additive wall brush. geometry building did not help. replacing the subtractive brush did not help. (behaviour is inconsistent. some new subtractive brushes created true (collision) holes, others didnt.) replacing the additive wall brush apparently solved the problem. (not a true fix though)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question