x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Odd Skeletal Mesh Rotations Upon FBX Import (Solved)

EDIT: I solved the problem myself. Was just some problems with the mesh being rotated incorrectly in comparison to the bones when being imported into Unreal Engine. The bone issue also is solved, by exporting at 6.1 ASCII format.

I have a strange problem upon importing FBX's into Unreal. Initially, I was using the fbx exporter version FBX 7.4 binary, however, this led to problems such as disconnected bones and bones being "missing from the bind pose" etc as seen in the image here. https://images-ext-1.discordapp.net/eyJ1cmwiOiJodHRwczovL2d5YXpvLmNvbS9mZWFiODgxNmQwZmM4YWE5NDk2MTVmZDk5NDM0OWQ3Ny5qcGcifQ.s-HBpe9CyXGmOk7Sxb_eDqyrJ4I Despite this, it seems animations work flawlessly... but I wanted to avoid this as we're all worried how much the above errors may affect performance.

I decided to try exporting at version FBX 6.1 ASCll. This completely avoids the errors seen above, and imports without problems... however, when I go to view the skeletal model in Unreal it has really odd default rotations. Blender rig/model: http://prntscr.com/dh1s1b Unreal Import: http://prntscr.com/dh1s6r I'd really appreciate some help here as it is extremely frustrating, plus it's kind of halting development on our project. It's not exactly reliable to find out the specific rotational transform values and tell them to the rest of the team upon importing. Cheers! - Nathan

Product Version: UE 4.14
Tags:
more ▼

asked Dec 08 '16 at 08:55 PM in Using UE4

avatar image

08nathan123
1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello

Is it possible to send the model? This could be 2 problems. 1 your model is too small so the armature is too small and it does not pick up which vertex the bone is weighed to. To fix this just take a look at 1 of my old models I imported into Unreal at this link https://youtu.be/DKfOaIXCN90

2 the bones are not weight painted.

more ▼

answered Dec 09 '16 at 08:34 PM

avatar image

Paul Swartz
231 8 5 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question