x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unable to Deploy AppLocalDirectory dependencies

Hi, we've been working on this issue for weeks and there doesnt seem to be a fix anywhere we've looked into.

UATHelper: Packaging (Windows (64-bit)): Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: Unable to deploy AppLocalDirectory dependencies. No such path: D:\KAMK\Project Apollo\SVN_SUPOLLO\Supollo\$(EngineDir)........\KAMK\Project Apollo\SVN_SUPOLLO\Supollo\Binaries\Win64\Win64 UATHelper: Packaging (Windows (64-bit)): em BaseWinPlatform.StageAppLocalDependencies(ProjectParams Params, DeploymentContext SC, String PlatformDir) UATHelper: Packaging (Windows (64-bit)): em Win64Platform.GetFilesToDeployOrStage(ProjectParams Params, DeploymentContext SC) UATHelper: Packaging (Windows (64-bit)): em Project.CreateStagingManifest(ProjectParams Params, DeploymentContext SC) UATHelper: Packaging (Windows (64-bit)): em Project.CopyBuildToStagingDirectory(ProjectParams Params) UATHelper: Packaging (Windows (64-bit)): em BuildCookRun.DoBuildCookRun(ProjectParams Params) UATHelper: Packaging (Windows (64-bit)): em AutomationTool.BuildCommand.Execute() UATHelper: Packaging (Windows (64-bit)): em AutomationTool.Automation.Execute(List`1 CommandsToExecute, CaselessDictionary`1 Commands) UATHelper: Packaging (Windows (64-bit)): em AutomationTool.Automation.Process(String[] Arguments) UATHelper: Packaging (Windows (64-bit)): em AutomationTool.Program.MainProc(Object Param) UATHelper: Packaging (Windows (64-bit)): em AutomationTool.InternalUtils.RunSingleInstance(Func`2 Main, Object Param) UATHelper: Packaging (Windows (64-bit)): em AutomationTool.Program.Main() UATHelper: Packaging (Windows (64-bit)): Program.Main: AutomationTool exiting with ExitCode=1 (Error_Unknown) UATHelper: Packaging (Windows (64-bit)): BUILD FAILED PackagingResults:Error: Error Unknown Error

The path the compiler is saying that doesnt exist, has been there all along.here's the compiler log

We also noticed that something called "none" is trying to call a map that was deleted months ago.

Product Version: UE 4.13
Tags:
more ▼

asked Dec 09 '16 at 12:36 PM in Packaging & Deployment

avatar image

popifrex
111 8 10 14

avatar image popifrex Dec 14 '16 at 01:28 PM

Shameless Bump (if that works here)

I noticed the duplicated path on the path, I fixed it, but somehow during the cooking it will always go somewhere else. And just clearing out the path in the packaging settings does not work, unreal adds one of his own always resulting in a wrong path again.

avatar image Samantha Sutton ♦♦ STAFF Dec 14 '16 at 06:23 PM

Popifrex,

Did you try deleting your Intermediate and Saved folders after you fixed the issue to ensure it's being properly recreated?

avatar image popifrex Dec 15 '16 at 07:18 AM

Just tried that, same error "no such path". How do I specify which path the automation tool should deploy to? In the packaging settings it doesnt work, the automation tool will just add whatever path it feels like on it.

avatar image Samantha Sutton ♦♦ STAFF Dec 15 '16 at 08:22 PM

Can I please see your newest error output logs? Please upload them as a .txt file.

avatar image popifrex Dec 16 '16 at 06:57 AM

here it is. Tried to empty the Applocal Prerequisites Directory as it is in an empty project with no success. unreal is still doing as it pleases.

link text

supollo.log (1.7 MB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

So we fixed it by deleting manually the ApplocalPrerequisitesDirectory in DefaultEngine.ini (Of the current project, not the engine). Just delete whatever the engine is writing on its own, it should look like this:

ApplocalPrerequisitesDirectory=(Path=)

After that we built and deployed it with no issues,

more ▼

answered Dec 16 '16 at 07:51 AM

avatar image

popifrex
111 8 10 14

avatar image unstormed Feb 10 '17 at 10:42 PM

Thanks a lot! I was having the same problem and this worked for me!

avatar image Bigodon Mar 11 '17 at 06:38 PM

@popifrex i think i'm having a similar problem, but my defaultengine.ini from my project don't have anything about "ApplocalPrerequisitesDirectory" could you paste there what yours look like, so i can try copy the section and paste on my file and see if it works. So fustrating and i think this is the culprit

avatar image popifrex Mar 13 '17 at 08:22 AM

Unfortunately I do not have unreal engine installed anymore, check other .inis in your project folder and check what they have. I'm afraid that's all the help I can provide atm.

avatar image qdessauvage Sep 19 '17 at 07:28 PM

Had same issue and I could find it in the DefaultGame.ini under [/Script/UnrealEd.ProjectPackagingSettings]

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question