x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Illegal call to StaticFindObject() while collecting garbage!

Trying to move my project from 13.4 to 14.1, got this message at 75% loading project: " The game module 'warcry' could not be loaded. there may be an operating system error or the module may not be properly set up " when i click ok, i got this stack :

 Fatal error: [File:D:\Build\++UE4+Release-4.14+Compile\Sync\Engine\Source\Runtime\CoreUObject\Private\UObject\UObjectGlobals.cpp] [Line: 230] 
 Illegal call to StaticFindObject() while collecting garbage!
 
 
 UE4Editor_Core!FDebug::AssertFailed() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\core\private\misc\assertionmacros.cpp:332]
 UE4Editor_CoreUObject!StaticFindObject() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:234]
 UE4Editor_CoreUObject!CreatePackage() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:579]
 UE4Editor_CoreUObject!UObjectBase::DeferredRegister() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\coreuobject\private\uobject\uobjectbase.cpp:160]
 UE4Editor_CoreUObject!UClass::DeferredRegister() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\coreuobject\private\uobject\class.cpp:2765]
 UE4Editor_CoreUObject!UObjectForceRegistration() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\coreuobject\private\uobject\uobjectbase.cpp:390]
 UE4Editor_CoreUObject!UObjectProcessRegistrants() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\coreuobject\private\uobject\uobjectbase.cpp:375]
 UE4Editor_CoreUObject!ProcessNewlyLoadedUObjects() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\coreuobject\private\uobject\uobjectbase.cpp:819]
 UE4Editor_CoreUObject!TBaseStaticDelegateInstance<void __cdecl(void)>::ExecuteIfSafe() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\core\public\delegates\delegateinstancesimpl.h:1018]
 UE4Editor_Core!TBaseMulticastDelegate<void>::Broadcast() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\core\public\delegates\delegatesignatureimpl.inl:922]
 UE4Editor_Core!FModuleManager::LoadModuleWithFailureReason() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\core\private\modules\modulemanager.cpp:429]
 UE4Editor_Core!FModuleManager::LoadModule() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\core\private\modules\modulemanager.cpp:327]
 UE4Editor_Engine!FModuleManager::LoadModuleChecked<IHotReloadInterface>() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\core\public\modules\modulemanager.h:288]
 UE4Editor_Engine!UNavigationSystem::CleanUp() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\engine\private\ai\navigation\navigationsystem.cpp:3573]
 UE4Editor_Engine!UNavigationSystem::~UNavigationSystem() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\engine\private\ai\navigation\navigationsystem.cpp:321]
 UE4Editor_Engine!UNavigationSystem::`vector deleting destructor'()
 UE4Editor_CoreUObject!IncrementalPurgeGarbage() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\coreuobject\private\uobject\garbagecollection.cpp:1025]
 UE4Editor_CoreUObject!StaticExit() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\coreuobject\private\uobject\obj.cpp:3881]
 UE4Editor_CoreUObject!TBaseStaticDelegateInstance<void __cdecl(void)>::ExecuteIfSafe() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\core\public\delegates\delegateinstancesimpl.h:1018]
 UE4Editor!TBaseMulticastDelegate<void>::Broadcast() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\core\public\delegates\delegatesignatureimpl.inl:922]
 UE4Editor!FEngineLoop::AppPreExit() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\launch\private\launchengineloop.cpp:3442]
 UE4Editor!FEngineLoop::Exit() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\launch\private\launchengineloop.cpp:2488]
 UE4Editor!GuardedMain() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\launch\private\launch.cpp:163]
 UE4Editor!GuardedMainWrapper() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]
 UE4Editor!WinMain() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\launch\private\windows\launchwindows.cpp:202]
 UE4Editor!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:264]
 kernel32
 ntdll


not sure what i'm supposed to do then, i fixed compilation errors ( ViewProjectionMatrix removed from FSceneView ) and it build fine in VS ( 14/2015 )

I've see similar report, but that was for 4.11 version .

Product Version: UE 4.14
Tags:
more ▼

asked Dec 09 '16 at 10:39 PM in Bug Reports

avatar image

Firefly74
1.5k 14 18 32

avatar image Tim C ♦♦ STAFF Dec 19 '16 at 11:10 PM

Hi Firefly74,

Sorry for the delay in getting back to you on this issue. Are you seeing this happen only in your project, or does this same thing occur if you create a new 4.13 project and upgrade it to 4.14? Are you using the binary version of the Engine that is installed by the Launcher, or did you build the Engine from source code? It sounds as though your project is a code project, and the project builds successfully in 4.14, correct?

The callstack that you provided looks very similar to what we were seeing in previous versions of the Engine. The test case that we had for the crash in 4.11 that you mentioned no longer results in a crash for us, so there is something else happening in your case that we have not seen internally. Any information that you can provide to help us reproduce this internally would be very much appreciated.

Tim

avatar image Firefly74 Dec 22 '16 at 10:35 AM

Hi Tim !

Just had a new try this morning, and got some new infos : - I tried a new 4.13.2 and moved to 4.14 ( sample fps ) and it worked fine - I use Binary version - code project and it build fine ( had some porting typo to do, but fixed it ) ( still got some small warnings (BeginPlay and staticMesh access, so nothing that could harm )

At 71% i have " The game Module 'Warcry' could not be loaded. there may be an operating system error or the module may not be propoerly set up"

then at 75% i got the crash i posted here in the first place.

Didn't saw the message came before and not at the same time. still no idea what to do

so it say it "can't be loaded by the os", -file is present, -tried with anti-virus disabled - if i try to only do "lunch game" same error ( + crash )

avatar image Firefly74 Dec 22 '16 at 10:51 AM

i did some more investigation with procmon to see what was happening, looks link one of my pluggin doesn't load

first one load fine ( UE4Editor-DPGPlugin.dll) Game module load fine ( UE4Editor-Warcry.dll ) But the it try many other places to load the UE4Editor-DPGPostProcess.dll which 'obviously' is C:\Warcry\WarcryUE\Warcry\Plugins\DPGPostProcess\Binaries\Win64\UE4Editor-DPGPostProcess.dll

I checked the .uplugin file but nothing wrong ( looks like the other one that load fine )

Procmon data : link text

promonlog.txt (13.4 kB)
avatar image Tim C ♦♦ STAFF Dec 29 '16 at 09:28 PM

Sorry, I didn't notice that there were some plugins involved. Could you please double-check and make sure that your .uproject file, as well as the .uplugin file for each plugin being used, show that the plugins are enabled?

If they are all enabled and the issue continues, could you provide more information about how the plugins interact with each other and the project? Alternatively, would it be possible to get the 4.13 version of the project to take a look at so we can try to see what is happening there when it is upgraded?

Tim

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Pluggins were not all registered in UProject file, strange ( as they were active and usable before ), now it load without troubles.

Maybe having some better Error messages would be possible for theses king of things .. ( might not be easy if loading architecture isn't meant for that )

Anyway, thanks a lot for your help ! Happy new year to you and have a good day ! :)

more ▼

answered Jan 02 '17 at 12:34 PM

avatar image

Firefly74
1.5k 14 18 32

avatar image Tim C ♦♦ STAFF Jan 03 '17 at 03:54 PM

Hi Firefly74,

I am glad to hear that you have been able to get things working again. There seems to have been a change in 4.14 that now requires plugins to be specifically enabled if they are being used in a project. This change isn't something that I recall seeing mentioned in the release notes, so I apologize that the information wasn't available to you. So far it seems to only be a problem in projects that are using multiple plugins with some of the plugins being dependent on other plugins.

I have not yet been able to reproduce this issue internally. I don't think I am correctly setting up the plugin dependencies that result in this issue when a project is upgraded to 4.14. If you happen to have more information about how your plugins depend on each other, or a small sample project that demonstrates the issue, that would be very helpful for us to try to guard against this issue in the future.

Tim

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question