x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Build Failed: Error Launch Failed! Unknown Error.

Hello. I am currently developing a project in UE4.13.2 and for whatever reason I cannot seem to build my project (which is targeted for PC and HTML5.) Specifically, when trying to build I encounter the following fatal error:

 LogPlayLevel: UnrealBuildTool: LINK : fatal error LNK1181: cannot open input file 'libsndfile-1.lib'

I've tried verifying VS2015 Community as well as my Engine UE4.12.3 files and this hasn't seemed to help. Does anyone know where this file is supposed to be located locally? What packages does this library usually come in? (I also tried uninstalling and reinstalling Engine prerequisites.)

Anyone know what may be causing this or have any suggestions for steps I can take to resolve this?

Thank you very much.

Product Version: UE 4.13
Tags:
more ▼

asked Dec 12 '16 at 08:12 AM in Packaging & Deployment

avatar image

DesertEagle_PWN
149 9 23 23

avatar image Samantha Sutton ♦♦ STAFF Dec 12 '16 at 04:30 PM

DesertEagle_PWN,

Make sure that you did not include an 'AnimGraph' as one of the Additional Dependencies. If you have, please remove it and everything should compile just file.

Let me know whether or not this works for you, thanks!

avatar image DesertEagle_PWN Dec 14 '16 at 06:37 AM

Hey Samantha, AnimGraph shouldn't be a dependency (I checked last night while researching this issue and don't remember seeing it) but I can check again when I get back to development later today. In the meanwhile, assuming the AnimGraph dependency isn't a problem, are there aren't other things you could suggest?

Thanks in advance.

Update: I have confirmed that AnimGraph is not an additional project dependency. It is absent from the additional dependencies list inside the .uproject.

avatar image DesertEagle_PWN Dec 14 '16 at 06:38 AM

Sorry for the delay; accidentally posted my reply from yesterday as an answer; so you probably did not receive any notification.

avatar image Samantha Sutton ♦♦ STAFF Dec 15 '16 at 10:29 PM

Thank you for double-checking that the AnimGraph wasn't included as an additional dependency.

Libsndfile is a C library which is used to for reading and writing files containing sampled sound. You might need to simply download it.

Check this AnswerHub post out. If that doesn't help any, please answer the following and I'll continue to investigate.

  • Have you tried deleting your Intermediate and Saved folders from the project?

  • Have you tested in 4.14.0 or 4.14.1 to see if the error persists through an upgrade?

  • Is this project a full C++ project?

Thanks!

avatar image Samantha Sutton ♦♦ STAFF Dec 19 '16 at 10:32 PM

Hey DesertEagle_PWN,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you!

avatar image DesertEagle_PWN Dec 21 '16 at 02:08 AM

Hey Samantha, sorry for the late reply; I didn't get the notification of your post so I didn't respond.

Currently this problem is not resolved. In addition to the steps mentioned before, here are the additional steps that I have tried:

  • I have confirmed that "AnimGraph" and "UnrealEd" are not in my .uproject's additional dependencies list

  • I have deleted my project Binaries, Saved, Intermediate files and VS solution and regenerated/rebuilt them for my project's current engine version (Version: 4.13.2-3172292+++UE4+Release-4.13)) using the Development Editor build configuration.

None of the suggestions from the linked threads have yielded any benefit as they all pertain to regenerating the project Binaries/Saved/Intermediate files or checking for the additional dependencies mentioned.

Any further assistance on this would be greatly appreciated.

Edit: I also forgot to include the following information:

  • The project is a C++ project that also makes use of blueprints, especially for UI (UMG Widgets)

  • Using the same engine installation and VS configuration I am able to build, package and deploy a blank C++ project with no errors.

avatar image Samantha Sutton ♦♦ STAFF Dec 22 '16 at 09:58 PM

I am not able to reproduce this error when creating a first person template project with UI in it. Could you please check to see whether or not 4.14.1 works for you?

Have you tried migrating your project over to a newly created project to see if that fixes the issue too? I would not replace the old version with new until you've verified it's corrected the problem. Sometimes older files will throw out errors.

avatar image DesertEagle_PWN Dec 23 '16 at 03:08 AM

Hey Samantha, this is a C++ project and I have tried migrating all content to an otherwise fresh project. I was unable to "migrate" the project source through any safe means, so I copied the source folder to the new project folder. I am having difficulty in this area -- are there any specific steps I should take when migrating C++ Source to a new Code Project in 4.13.2?

My team really does not want to change engine versions until after launch if at all possible. Are there any other solutions or workarounds you could suggest so that we can actually get a packaged development build for deployment?

avatar image DesertEagle_PWN Dec 25 '16 at 02:41 AM

I also tried a complete engine 4.13.2 uninstall and reinstall. I still seem to be missing the same .lib, and I don't see it and here in the engine directories. where is this .lib supposed to live inside the engine folder?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

It lives in the Engine\Binaries\ThirdParty\Libsndfile folder. Here is a copy of mine, hopefully it'll work for you all.

Libsndfile-1.lib

more ▼

answered Dec 29 '16 at 06:16 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question