x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Editor Move Tool jumping around

Our level designer reported to me that since we moved to 4.14 the move tool had been changing the Z axis of objects even when he was only dragging using the X/Y axis of the gizmo. I thought he might have been confused by a blueprint with something in the construction script or maybe had some kind of surface snapping turned on but when I loaded up I had the same issue.

If I place an object into the world (such as a static mesh or particle system) and then try and drag it, it occasionally jumps around in any axis that it shouldn't be moving in. It moves instantly as if snapping and when it flicks back the gizmo is no longer centered on the objects pivot it slowly separates the more you drag it around.

alt text

Hopefully this demonstrates what I mean well enough. I have reset view settings to default and cannot see any snapping settings that are enabled.

Product Version: UE 4.14
Tags:
more ▼

asked Dec 12 '16 at 04:07 PM in Bug Reports

avatar image

mrcrocker
126 8 20 25

avatar image Matthew J Dec 14 '16 at 06:09 PM

Hello mrcrocker,

I'm trying to reproduce this but not seeing the same results. Does it only snap to other objects' locations as shown in your gif? Does it happen with completely blank assets like a freshly created particle system? Does it also happen in any project or only the one that you're developing?

avatar image mrcrocker Dec 14 '16 at 06:33 PM

I tested in a blank project and it doesn't seem to occur.

The object doesn't appear to be snapping to anything specific. Here is a gif of a static mesh being moved and randomly snapping around.

alt text

and here is one of a static mesh in a blank level also randomly snapping around.

alt text

I can't think of anything specific that could affect this. As far as custom code/plug-ins go we have only ever added Rama's Mouse controls that lets you move the mouse using a control pad. Everything else is the Epic launcher version.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Do you have this Rama plugin enabled and can you try using this plugin in a new project to see if that could be the cause? I've never used his plugin so I'm not familiar with it. It's sort of good that we've narrowed it down to only happening in your project. It means we can get an idea of what is causing it but it also means I likely won't be able to reproduce it, which is bad.

I would also suggest making a copy of your project's Config/Saved folder and then deleting the originals, in case something in the project settings is causing this.

more ▼

answered Dec 14 '16 at 09:30 PM

avatar image mrcrocker Dec 14 '16 at 09:51 PM

Clearing out the saved folder appears to have fixed the problem. Thanks for your help, I don't know what originally caused the problem but given the fix I think it is likely our use of Dropbox as a makeshift SVN caught up with us (although it has admittedly worked fine for over a year now)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question