x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Warning: Failed to load '/Game/FirstPersonBP/FirstPersonOverview': Can't find file '/Game/FirstPersonBP/FirstPersonOverview'

I am attempting to package a game that is running great in editor and getting 54 Failed to Load errors when attempting to package. Some of the referenced assets don't and shouldn't exist. For example the first full error:

 UATHelper: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.12.12-16.41.45:519][  0]LogUObjectGlobals:Warning: Failed to load '/Game/FirstPersonBP/FirstPersonOverview': Can't find file '/Game/FirstPersonBP/FirstPersonOverview'

In this case that folder/file indeed does not exist, nor should it, I started with a third person template. I have not reviewed all missing files, some appear they may be more relevant to the project. Here are the steps I have tried to fix this from other forum posts:

 Deleted intermediate, saved, and config from local project folder
 Right clicked content folder and selected fix up redirectors in folder
 Deleted intermediate and saved from user\AppData\Local\UnrealEngine\4.14
 Cloned the game from within Unreal, and then attempted packaging

None of these fixed the issue, and in fact the project stopped working in editor, so I returned the original files and everything works fine again in editor. What can I do to fix these errors and successfully build?

One other note, I may have created a C++ class at some point, however the project was a blueprint project prior. A team member is thinking, from his experience, these errors may actually be a result of not performing extra build steps required for C++ projects, perhaps this is related.

Product Version: UE 4.14
Tags:
more ▼

asked Dec 12 '16 at 04:57 PM in Packaging & Deployment

avatar image

edencorbin
21 3 6 10

avatar image Sean L ♦♦ STAFF Dec 13 '16 at 07:54 PM

Hello,

Could you please provide your full output log so I can take a closer look at the errors you're experiencing?

Thanks

avatar image edencorbin Dec 14 '16 at 01:34 AM

Thank you for looking into this. I should mention I have somewhat resolved the issue but am very interested in your response after reviewing the logs. What I did was create an empty blueprint project, then migrate my entire content folder from my old project (at the moment we only had one test c++ script so I did not include that). In the new project, after cooking my content I was able to successfully package the project and it runs fine. Please note that cooking the files did show errors, however it was successful, and then allowed me to package successfully. Linked are the original log trying to package the game and failing "fulllog.txt" and then the log of the working cook process in the new copy that demonstrates the errors that remain "cooklog.txt". I posted links as these files are pretty large. We are scheduled to release this project next year, and it is our first with the Unreal engine, I appreciate your time, and look forward to any insight.

http://www.testmycode.xyz/log_host/fulllog.txt

http://www.testmycode.xyz/log_host/cooklog.txt

One other question, how does this loglinker determine what files to try to find? It calls out files that indeed do not exist, but why? Can I clean up this process so it does not try to find them?

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

So what I'd recommend in the future for looking over logs is do perform a CTRL+F search for Error. Then you'll see the errors that are stopping the project from successfully packaging. Warnings as you posted in your originally question can typically be ignored.

So here's one that I see, as an example:

LogPackageName:Error: DoesPackageExist: DoesPackageExist FAILED: '/Game/BlueprintKeyRemapping/ExampleMap/FirstPersonExampleMap (2)' is not a standard unreal filename or a long path name. Reason: Name may not contain the following characters:

This is an issue because your map name contains a space, which is not allowed for file names. Removing that space would resolve that particular error.

I also noticed a few errors seemingly related to p4, so I'd also recommend looking into those if the issue pops back up.

As far as the can't find file warnings go, these can typically be ignored unless it's a file that you know for sure that you are using. I'm not aware of a way to clean up the process that looks for the files, unfortunately.

Let me know if you have further questions, and I'm glad you were able to get the project to package successfully.

more ▼

answered Dec 14 '16 at 03:56 PM

avatar image

Sean L ♦♦ STAFF
44k 485 149 438

avatar image edencorbin Dec 14 '16 at 05:10 PM

I can confirm that was it, it worked after removing this map. I believe the plugin auto generated that map when we installed it, perhaps due to an existing map of the same name.

avatar image edencorbin Dec 14 '16 at 05:20 PM

Oh one other question, there were 100 errors, other then your background/knowledge with Unreal, any way you picked this out as the culprit?

avatar image Sean L ♦♦ STAFF Dec 14 '16 at 05:22 PM

Basically what I'd do normally is just go through and fix those errors. Most of the errors were p4 related, so I figured the one unreal-related one would have been the culprit in this case.

(comments are locked)
10|2000 characters needed characters left

Possible Solution That Worked For Me :D

  1. Close UE4

  2. Delete everything inside 'Intermediate' Folder

  3. Delete everything inside 'Saved' Folder

  4. Uninstall current UE4 Engine Version

  5. Reinstall UE4 Engine Version

  6. Recompile and do the Happy Dance ^_^

more ▼

answered Nov 28 '17 at 07:44 PM

avatar image

lennysunreal
117 13 18 22

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question