x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unable to view UE in OSX

  • Moved from UE Forums ** Sorry if this is a double post -

The UE 4.1 was working fine, then I upgraded to 10.10 and started having this issue. I've since done a clean install of OSX 10.9.3 and I'm still experiencing the same issue. I've updated all software, tried UE 4.1 and 4.2 but still have the same problem.

The issue is that the editor itself ( launcher is fine ) is completely colored and text is unreadable. I've attached a screenshot for example. I'm not entirely sure what to do at this point, I figured a complete OS wipe would have resolved any problems.

When clicking by memory the editor appears to load up, all the sections seem to be there, but it's impossible for me to tell whats going on. If I attempt to run a project from the market place ( I've tried tappy bird & the office ) they crash after attempting to load. I've attached the Callstack from one of these failures.

System:

OSX 10.9.3

Macbook Pro mid-2009

Processor 2.8 GHz Intel Core 2 Duo

Memory 8 GB 1067 MHz DDR3

Graphics NVIDIA GeForce 9600M GT 512 MB link text alt text

**Edit: Forgot to add callstack

Product Version: Not Selected
Tags:
more ▼

asked Jun 07 '14 at 07:22 PM in Bug Reports

avatar image

devdavi
1 1 2

avatar image ZeroEightSix STAFF Jun 09 '14 at 03:48 PM

The Launcher is using different, simple renderer. The editor is using the full renderer for everything.

In UE 4.2 we've added experimental support for older graphics cards that are limited to OpenGL 3.3, so your case is very strange. Could you please go to your ~/Library/Logs/Unreal Engine, find a log from running the editor and attach it here? It should contain some info about your graphics card, like the list of supported OpenGL extensions. Thanks!

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi devdavi,

Unfortunately the editor needs a Mac that can support OpenGL 4.1. Given your Macbook's specs, the editor may run, however you will continue to have fairly drastic performance related issues, including the blue screen. Overall this pc may not be the most efficient option to run the Unreal Engine on given its age and specs.

more ▼

answered Jun 09 '14 at 03:29 PM

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question