x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Fail to package Google VR cardboard and sign it

I have tried to package my Cardboard Project and then try to upload to google play but it only package when I don't sign it. I have followed the specific guide https://docs.unrealengine.com/latest/INT/Platforms/GoogleVR/QuickStart/index.html but it doesn't work with that specific NDK, SDK, apache, JAVA and android-21 in both (sdk and ndk).

I have my own firm (.keystore) in the correct folder and I have done a signed project succesful but when I change to VR It doesn't work.

I am a little desperated because I have tried everything (change to newest versión of NDK, java...) and even trying solutions of other posts but it does not work for me.

I include my log file when I try to package it.link text

I hope someone could help me because I think that the error (D:\NVPACK\android-sdk-windows\tools\ant\build.xml:871) is the guilty but I don't find anything about it in google or the forum.

Product Version: UE 4.14
Tags:
log.txt (331.8 kB)
more ▼

asked Dec 14 '16 at 10:58 AM in Packaging & Deployment

avatar image

jcamagu
11 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hi,

I think this is what is stopping your build: Program.Main: ERROR: AutomationTool terminated with exception: System.IO.FileNotFoundException: No se pudo encontrar el archivo 'E:\UnrealProjects\PruebaVR2\Intermediate/Android/APK/bin/PruebaVR2-release.apk'.

Your folder path seems incorrect, especially the slashes in your 'Intermediate' folder path changes from back slash to front slash.

Thanks d0d0

more ▼

answered Dec 14 '16 at 06:07 PM

avatar image

d0d0
477 16 8 18

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

But I think that it is generated automatically by the program because it is a temporary folder, isn't it? It is curious that if I compile it without signing it, it works. So I think that the problem is related with other thing because I am not able to generate that file in that path or what is generating this file or how?

Thanks by the response.

more ▼

answered Dec 14 '16 at 07:00 PM

avatar image

jcamagu
11 1 2

avatar image d0d0 Dec 14 '16 at 07:47 PM

You are right, it is generated automatically. This is not really an issue. If signing and building is causing it, then I suspect proguard is causing it. Maybe the proguard is obfuscation is enabled and it is not able to read some class names ?

Thanks

avatar image jcamagu Dec 15 '16 at 09:40 AM

When you refer to proguard is "unreal proguard" or windows, because I have desactivated firewall and security of windows and when I compile again It does no work. What I have done is start new project without plug in Google VR activate and with options of sign, "full rebuild" and "for distribution" activated; and It works perfectly. The build is correct. But when I activate google VR plugin, restart and even deleting folders (intermediate and saved as some post recommend) the build does not work. Logically I activate some option of VR (look the images I atach).

I continue doing tests changing some parameters step by step and seeing if one of them is the guilty of doesn't compile with sign.

Thanks a lot for the help.alt text

01.jpg (42.6 kB)
02.jpg (95.5 kB)
03.jpg (99.2 kB)
avatar image RVillani Jan 04 '17 at 07:08 PM
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Yeah thank you very much. Finally it worked installing SDK from Unreal folder.

more ▼

answered Jan 04 '17 at 08:15 PM

avatar image

jcamagu
11 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question