x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Baked lighting not working on Foliage LODs with Lightmass 4.14

After upgrading our project from 4.13 to 4.14 and performing a Build Lighting (same Lightmass settings, objects & materials as in 4.13), all of our instanced foliage objects' LODs do not utilize the lightmaps (only the highest LOD of all the foliage is properly lightmapped).

This does not occur if the same objects are placed as regular static meshes (instead of using the Foliage tool) - in this case, then the LODs do use the Lightmaps properly. The only difference is whether they are placed with the foliage tool or not.

This problem did not occur in 4.13. This is a major showstopper for us, as we cannot perform a good light bake with 4.14.

(Images attached)

Anyone else seeing this issue?

Product Version: UE 4.14
Tags:
more ▼

asked Dec 15 '16 at 01:49 AM in Using UE4

avatar image

glen.schulz
11 1 2 5

avatar image imskull Feb 16 '17 at 08:29 AM

I just confirmed it had been fixed in 4.15, good job!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Glen,

We've had a ticket in for this one for some time and it's affected more than just 4.14.

https://issues.unrealengine.com/issue/UE-32299

Right now it's on the TODO list for 4.16, but that could always get pushed depending on priorities.

-Tim

more ▼

answered Dec 15 '16 at 09:46 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 887 101 878

avatar image glen.schulz Dec 15 '16 at 09:58 PM

Thanks for the reply, Tim.

This wasn't a problem in 4.13 though...

What is the recommended solution? Not using the foliage tool, and converting all foliage assets to static placed meshes? We are actually doing a forest map, so the foliage tool is almost essential for us.

Do foliage meshes have a more optimized rendering path, or is the foliage tool strictly for convenience of populating a level with assets?

Thanks very much, -Glen

avatar image Tim Hobson ♦♦ STAFF Dec 16 '16 at 09:03 PM

Hey Glen,

After getting a moment to look at this one the ticket I linked above is for a similar but separate issue. The one here it looks like the lower LODs are ignoring or dropping the baked lightmap altogether. I've submitted a new ticket for this issues specifically since it's a regression in behavior. Hopefully, we can get this resolved soon.

https://issues.unrealengine.com/issue/UE-39884

Thanks!

avatar image glen.schulz Dec 16 '16 at 10:48 PM

Good news! Thank you very much, Tim! Should I watch this thread for an update?

avatar image Tim Hobson ♦♦ STAFF Dec 19 '16 at 02:43 PM

The ticket will have the most up to date information. I don't typically repost back on these unless the tickets are kicked back as "won't fix" or "invalid" with indications of how something should be setup vs what was reported in the ticket.

With this being a regression I would expect there to be some form of traction on this one soon.

avatar image glen.schulz Jan 03 '17 at 07:46 PM

Hi Tim,

I noticed that the Target Fix for this is 4.16.. is this accurate, or is there a planned hotfix for this for 4.14?

Thanks very much, Glen.

avatar image Tim Hobson ♦♦ STAFF Jan 03 '17 at 10:31 PM

After the hotfix for 4.14.2 coming up, there aren't any more planned hot fixes. 4.15 has already branched so that will likely only be bug fixes for the most part. 4.16 is targeted as the work for this one, but no fix has been submitted yet so I can't push to see if we can even try and get this into 4.15 until that's submitted. Hopefully, a fix will be submitted before we ship 4.15. Not much I can do until a fix is in though and verified.

avatar image brisck1 Jan 05 '17 at 04:23 AM

Hi Tim, just wanted to chime in and say I've hit a wall with this bug and I really hope the fix makes it into 4.15. On a similar note, i've also run into this problem with foliage instances: https://answers.unrealengine.com/questions/543338/important-lightmass-settings-missing-from-foliage.html

avatar image tech1187 Dec 01 '18 at 10:45 PM

Apparently this bug has yet to been fixed. I have been dealing with this issue since 4.14 up to presently 4.20. When will this issue be fixed?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question