x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Why are some input actions working and other not?

I have been using input actions for some time now and for some reason, all of a sudden, they are not working. I have your typical WASD movement input actions setup and they work fine. I have mouse X, and Y input axis setup and they work fine. I also have jump (spacebar) setup and it also works fine. On top of those I've setup some custom input actions for Right click and middle mouse click. They are setup in code. I've put debug on screen messages to test them and both work fine. But now, when I add any new input action, using any key or mouse, the input action does not fire. I've tried checking this in blueprints using print to screen, and also in code. They simply do not fire. Yet the other input actions I listed above all still work. This doesn't make any sense. I've tried adding a new mouse button input action, and also keyboard input actions. They just do not fire. Anyone experienced this and if so, how do I fix it?

Product Version: UE 4.13
Tags:
more ▼

asked Dec 15 '16 at 02:53 PM in Using UE4

avatar image

Thumper
966 141 150 389

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Are you perhaps trying to call these input actions in a blueprint that isn't set to take player input?

https://answers.unrealengine.com/questions/134435/input-action-mapping-not-firing.html

more ▼

answered Dec 15 '16 at 07:11 PM

avatar image

CometGoat
269 4 8 13

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question