x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Possible bug with emissive lighting

I've been working on a more "full featured" time of day system and I'm up to implementing proper moon phases but have run into a problem.

I really need the moon to be using the unlit lighting model however when I do this the dark side of the moon appears to punch through the cloud layer (see attached image). I would expect that when a material is emitting solid black, then this should not happen because is true physically based lighting you cannot "emit" black. If that makes sense.

Incidentally, the could layer is using the translucent lighting model.

Does anyone have an suggestions on how to get this to work.

Thanks.

alt text

Product Version: Not Selected
Tags:
more ▼

asked Jun 08 '14 at 05:52 AM in Rendering

avatar image

mrpdean
111 8 11 15

avatar image mrpdean Jun 08 '14 at 05:53 AM

Typo: the cloud layer is using the translucent lighting model.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi mrpdean,

I wish I knew the exact answer or could replicate this. But my first instinct would be to try passing your texture through some of the blend nodes in the material editor and see if it give you the desired result. Or you can try changing translucency priority.

If I get a chance I will try to replicate what you have going on.

Not that this is correct but along the lines of this route alt text

alt text

blend.jpg (389.5 kB)
opacity.jpg (363.6 kB)
more ▼

answered Jun 08 '14 at 06:32 AM

avatar image

Isaac Nichols
363 24 23 30

avatar image mrpdean Jun 08 '14 at 08:17 AM

Hi unrealguy,

Thanks for taking a look. It turned out to be a really simple/stupid mistake.

I just needed to clamp the black as the issue happens when "emitting" colors outside the zero to one range.

In my case, my calculations were resulting in a black that was less than zero.

All good now.

Thanks!!

avatar image Isaac Nichols Jun 08 '14 at 05:43 PM

Cool, glad it's working.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question