x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Light Functions Broken After Switching To MSAA?

I just converted my project from 4.13 to 4.14 and switched to MSAA as my anti-aliasing method. Now it seems all my light functions aren't showing up. Switching back to Temporal or FXAA doesn't help.

I tried setting up a new light and new material with no luck. Light functions seem to work if I make a new project and switch to MSAA.

Product Version: UE 4.14
Tags:
more ▼

asked Dec 16 '16 at 09:35 PM in Rendering

avatar image

jejunus
28 3 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Jejunus,

I've not been able to reproduce this on my end when converting a project from 4.13 to 4.14 or even just a 4.14 project.

  • Have you enabled Forward Shading via the project settings for this project before converting? As a note, MSAA is only supported for Forward Shading.

  • Did you enable MSAA in 4.13 before converting?

Since you say this issue isn't blocking you in a newly created project, you can try deleting the intermediate and Config folders in your project folder. This could clear some possibly corrupted information and when the config folder is deleted this will reset any setting you've set in the project settings or editor preferences, but it possibly a way to resolve your issue. You don't have to delete necessarily, you can simply move to another folder if you intend to move these back after checking.

-Tim

more ▼

answered Dec 19 '16 at 02:54 PM

avatar image

Tim Hobson ♦♦ STAFF
48.7k 888 103 880

avatar image jejunus Dec 27 '16 at 06:29 PM

Tim,

Thanks for your quick response, sorry I didn't get back to this sooner.

Still not working, and now I can reproduce in a new project. I narrowed it down to simply enabling forward rendering. In my existing project I deleted Intermediate and Config. After rebuilding, I confirmed that Light Functions were working. Once I enabled forward rendering, restarted and let the materials recompile, the light functions weren't working anymore.

In a new project all I did was: 1. made a new map 2. added a light 3. assigned the light a light function material and confirmed it was working 4. enabled forward rendering in project settings (aa still temporal/default) 5. restarted 6. light function material no longer having any effect on light

Any ideas? Thanks for your time.

—j

avatar image jejunus Dec 30 '16 at 11:40 PM

Just saw "Light functions and IES profiles" as being NOT supported by the forward renderer in the 4.14 release notes. I don't know how I missed that! Case closed I guess.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question